SHADOWS in render display mode

display
shadows
render

#1

Hi,

I wanted to try the new appearance of rendered display mode with shadows etc. But as you can see at attached pictures, something goes wrong. Shadows on individual objects shows and disappears according to selection. Dont know if problem is on my laptop - I had some trouble with open GL and drivers earlier, or there is some view mistake…

Thank for replies :slight_smile:
Petr


(Brian James) #2

Can you copy and paste the contents of the SystemInfo command here? Might be GPU driver related.


#3

Here it is

Rhino 6 SR0 2016-7-12 (Public Build, 6.0.16194.9151, Git hash:d4aced12b1ac047ef04e99f0bd2741e0c34595fc in branch n/a)

Windows 7 SP1 (Physical RAM: 3.9Gb)

NVS 4200M/PCIe/SSE2 (OpenGL ver:4.4.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: NVIDIA Corporation
Render version: 4.4
Shading Language: 4.40 NVIDIA via Cg compiler
Driver Date: 11-25-2014
Driver Version: 9.18.13.4121
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB


(Brian James) #4

The first thing I’d try is updating your driver. You can use http://wiki.mcneel.com/rhino/5/video/troubleshooting if you need help doing that from Nvidia’s site. You may have to do it from the laptop manufacturer’s site if they require certain drivers. In either case, you should make a back up of your system before changing the driver. I don’t have this specific graphics card here to test with but @jeff may. Post the 3dm too if you can so were looking at the same geometry.


#5

Well…driver update helps. Two years old driver…no wonder.
And must admitm, it it looks really cool. Look forward to use it at full capacity.

Thank you Brian :slight_smile:

Petr


#6

Maybe something…I tried to use adjusted technical view in layout…other display modes were ok, but this one is making lsd effect for free.


(Brian James) #7

If you can post the 3dm please do so and I’ll check technical mode here. If you adjusted the technical mode, please export the display mode from Options>View>Display Modes and include that as well or let me know what you altered so I can copy it here.


#8

Mhm, it looks like more complex problem.

Not only technical display, but also artistic and pen are making the same wierd appearance. Sometimes Rhino stucks when i am trying to change display modes in layouts…

layout display modes.3dm (106.9 KB)


#9

Note: Nothing changed - display modes stay as deafult

Petr


(Brian James) #10

Thanks, I see this too in Layout details here. Filed http://mcneel.myjetbrains.com/youtrack/issue/RH-34930


(Brian Gillespie) #11

RH-34930 is fixed in the latest WIP