OpenGL glitch in latest build

Don’t know what changed but these splotches just showed up.

Rhino 6 SR0 2016-5-24 (Public Build, 6.0.16145.13021, Git hash:0874b8e7b54943c5e98c066f064109bf4ab81dca in branch n/a)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Quadro 4000/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 362.13)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 3-18-2016
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Is there some reason you didn’t post the file?
Are you using a customized display mode? If so, please export that and send it too.

Hi John, yeah the reasion is that I don’t think it’s the file. Just installed the latest build and it’s the default render mode. It’s similar looking to the artifacts that Jeff fixed a few months ago, maybe it’s related.

Yeah, it seems related to the last issue we had when “splotches” appeared.
Here I tested it with plaster and plastic, and then lowered the reflection settings.
Plastic works fine until it hits 0% reflectivity.
I recall that @jeff found the cause last time this appeared on older nVidia cards.

Hmmm, black snow where you are… ? :smile: -Mitch

Yes, this oil nation still runs on fossil fuel… :wink:


Thanks for reporting! I will take a look at this sometime tomorrow to see if I can reproduce it.


@Holo I am not able to reproduce it on my computer. Could you try this week’s WIP to see if it has been fixed there?

Tagging @jeff for insight.

Hi David, do you have a computer with an older nVidia card?

Here’s the link to the thread from last time this happened:

hey @Holo, @Mitch , Does your scene have the ground plane turned ON? If so, does the “snow” go away when you turn off the ground plane?

I’ll try to repro this today with my older GF cards.

Thanks guys.

@jeff I haven’t experienced this problem myself - my only contribution to this thread was a small joke…

Hi All,

I believe I found and fixed this problem last week… Please check the latest WIP and let me know if I’m wrong.


Hi Jeff, I’m sorry, but I just checked today and the WIP claims it is the latest build.
Here are two objects, one with 0% reflection and the other with 1% reflection

A new WIP didn’t go out. These was a serious problem that didn’t get fixed and tested in time so we postponed it for a week.

Ah, good, thanks!

(All good in latest build, tested with Quadro 4000)