The document could not be autosaved

Hi there,
When I return to my workplace after a longer break I have to Force quit Rhino since the error “The document could not be autosaved. The file doesn’t exist” shows up. The original file is located on a server but that was never a problem until now. It’s very annoying since the file can’t be saved/duplicated manually anymore and the objects can’t be copy-pasted into another file.

Any suggestions?

Sorry for the very delayed reply. Are you still experiencing this problem in the latest Rhino update (5.4.2)?

Do you have any special characters in the file name? I have seen some other applications have problems autosaving those.

@dan I think the problem is gone with 5.4.2 since I haven’t seen the error for a while :wink:
@bigjimslade There have not been any special characters in the file name

1 Like

@dan I think the problem returned with version 5.5.2. I don’t experience it that often anymore but it still happens especially when working on large files located on the server. Maybe it is also our network connection which interrupts for a second. Anyway it’s very annoying that the file can’t be re-saved or overwritten in this case. I need to force quit and sometimes loose the last 10 minutes of work since the last auto-save.

Hello, I am experiencing this same issue with Rhino6 for mac when working “Live” on my Google Drive Local disk. Also never have I experienced that until now.

Hi - Can you reliably reproduce this, and, if so, can you provide clear steps to do so?

Do you know what has changed on your system?
-wim

I am not sure, I installed Catalina since it came out and I have had rhino6 since a while ago. I usually work Live on many files from google drive and icloud and never have had this issue. Now, every time I open a file it says this file cannot be autosaved, and then I have to export or duplicate in order to save it, it does not even let me save as and replace the file.

I have the same problem with Rhino Version 6 (6.22.20028.13212, 2020-01-28) on Catalina v 10.15.2 working live on GoogleDrive. Can not be sure when it began (in the last couple of months), and I keep my OS and Rhino regularly updated. Anecdotally, I’m having a similar problem with microsoft excel.

Same autosave problem, as well. You’ll notice I also had to save a new version… :upside_down_face: :thinking:

In the meantime, I believe I solved it myself in the same way that the Excel problem was fixed. Rhino needs ‘Full Access’ to the hard drive including GDrive. See below. I hope someone else finds this useful…

The problem remains (or has come back). I’m keeping all my software updated and it’s not getting better. I know it’s not the topic here, but I have the same problem with MSOffice documents.
Does anyone have a clue to why this is happening and how to solve it?

Hey there.
I had/have the same issue with “this file could not be saved”.
Only happened when I would save in a location that is synched on Google Drive.

Solution (this far) for me:

  • go to system preferences/privacy/full disk access
  • hit the “+” button, find google drive, click “open”
  • this tells you to quit and re-open google drive to allow full disk access, do that.

Seems to work now.
good luck.