The document could not be autosaved

I sometimes get the message below when I try to save my document. If I click SaveAs the document is saved to the file. My problem is that I am automating Rhino from Python, and this pauses the script. Is there a way to get around this?

I have set the FileIO.FileWriteOptions() to

opt = FileIO.FileWriteOptions()
opt.SuppressDialogBoxes = True
opt.UpdateDocumentPath = True
opt.SuppressAllInput = True
opt.FileVersion = 8
doc.WriteFile(f"{src_path}/{file_name}", opt)

RhinoApp.RunScript(“Exit”, True)

I have also granted rhino8 “full disk access”
The document is not being saved to a synced folded (iCloud)

Version : 8.5.24072.13002, 2024-03-12

Can you help me out?

Hi Johan-

Interesting use-case. I’ll need to see if I can reproduce that here.

In the meantime, you can use TestToggleMacAutosaveVersions to disable the macOS Autosaving/Versions feature used in Rhino for Mac.


Hi @dan

Thank you for getting back to me! I didn’t know that it was possible to turn off this feature. I will try this and see if it solves the problem. Thanks!

Think of this as a temporary workaround, rather than a long-term solution. I’m going to investigate this a bit more as I’d like this to be more graceful, if possible.

1 Like

I’m tracking this here:

RH-81486 Autosave (Mac): Do not trigger autosaves if GH definitions are solving or Scripts are running

You could save me a bit of time if you could provide the sample script that triggered this behavior.