Texture wrapping a box

I’ve seen a couple of similar topics but for the life of me I can’t figure out how to apply a 6 side unwrapped texture to a box.
I remember doing that in the past and it was really simple: I chose box mapping with divided space option and the texture was applied correctly.
I’ve tried to use the UV editor but I still don’t get it.
Is there a tutorial or some instructions how to do that ?

Hello - use Unwrap and select the seams that you want to open up, and then use the UV Editor.

Any luck?


Thanks Pascal, I’ve tried that before but in the UV editor, when prompted to draw a rectangle the aspect ratio doesn’t lock to the one of the texture so I have to rotate and then scale in each direction the UV’s to match the texture, is this normal ? It is hard to be precise because I can’t snap to the texture itself obviously … Eventually I get it but I’m not sure I’m doing it correctly. Also, if I try to delete the UV mesh that the UV editor creates, I can’t, I get a message: "Unsupported mesh operation blah bla " How the heck I delete the flat mesh once I’m done mapping ?

Nevermind the second question … the mesh disappears when I hit ‘Apply’

Hi Juan - if I choose the seams like so:

then the UV ediutor sees the mesh like so:

That is what you expect, right?

The rectangle is constrained, here, when I draw it.


That’s what I do but the rectangle is NOT
constrained. I don’t see that yours is either, the base and
top for example are rectangular on the box but almost square in
the UV map …

    I would expect the flatten mesh to be the same than the unwraped

box if I was to unfold it.

    Sorry I don't think I understand the process ...

Ah, OK, I thought you were referring to the base texture rectangle that the mesh is sitting on. That is constrained to being square and the texture is square.


Gotcha, so I’m the one that needs to draw a square (constraining the window with Ctl) regardless of whether the texture is square or rectangular and then the created mesh matches the proportions of the map inside the square. I understand now !!
However, I just noticed that choosing “Use material” only displays everything gray, not the actual texture …