Texture on Mesh Not Rendering or Rendering Incorrectly

I am fairly new to Rhino and this is my first post, so please excuse me if this the wrong method/place.

I am having trouble with a 3D statue model I downloaded not rendering correctly. Attached is the image file I am using that came with the download (lady.jpg). There seems to be two issues: how the statue looks in the Rendered VIEW is not correct, and how the statue looks in the actual RENDERING is not correct, but they are different from each other.

Attached are several images of the rendered views and renderings, in addition to various settings I have attempted to change. In RenderedView_Both.jpg you can see how the statue SHOULD look on the left, in both the rendered view and rendering. The statue on the right is after I attempted Rebuild Mesh. However, though the one on the left looks correct in the Rendered View, it shows up as grey in the actual render (Render_Match.jpg). Images Render_WCS, Render_Viewbased, and Render_Striped are all examples of various renderings when I change the settings (Settings_Mapping0, Settings_Viewbased).

I tried Matching the statue on the right using the (correct) statue on the left as the source object (Settings_Match) but that did not fix the issue (Render_Match). In the rendered view, the one on the left still looks correct (RenderedView_Match). No matter what, though, the statue that looks correct in the Rendered View always shows up as grey in the actual render. Even if I just choose a simple color as the material for the layer, it still shows up as grey in the actual render, and the Rendered View does not change based on the new color.

I am not sure where I am going wrong here, so any help or guidance is greatly appreciated. Thank you in advance.



Settings_Match











we could say more if you include a .3dm or tell us where we can download the model

however, most likely the mesh will have texture coordinates already, and anything you do (applying a texture mapping, using a wcs/ocs mapping, etc) will tend either to not use those texture coords, or to destroy them

in other words, the texture should use “mapping channel” mode with channel=1, and the mesh should not be modified – so try starting with an empty 3dm, import the mesh again, and set up a material with the texture just assigned to the material color, and using mapping channel 1

Thank you for your quick response. I have attempted what you suggested, opening a new file, importing the obj, and creating a new material for that layer and adding the texture to it, using mapping channel 1. I am getting the same result. Here is the test file I am using.

Below is a screenshot of the settings I used.

so it appears you are using rhino 6; it is too long ago for me to remember how rhino render worked back then, and what might be causing not to render that texture

however, you can use the superior cycles raytraced display mode instead:

but … on a hunch I just ran ComputeVertexColors and got this in rhino render:

Thank you again for your response. I am actually using Rhino 5, so could that be the issue? It’s too outdated to render a texture on a mesh? I tried adding an open surface and a simple open mesh to the same file, all three objects are on the same layer, and the rectangle and pyramid render fine (or at least using the correct texture/image), while the sculpture does not.

As I am using Rhino 5, I don’t believe the raytraced display mode is available to me. I also tried the ComputeVertexColors which gave the same result as before.

not sure what to tell you, the old rhino render just seems not to like this mesh for whatever reason; I tried in rhino 7 where we could still choose “legacy rhino render” as the render engine, and it behaves similarly

funny enough, I actually happen to have a rhino 5 here, so I a) opened the file, b) fixed the texture path to point to the jpg file on my drive, c) ran ComputeVertexColors, and I get this in rhino render:

my rhino 5 is

Version 5 SR14 64-bit
(5.14.522.8390, 5/22/2017)
Commercial

the same steps work similarly here in rhino 6, and in rhino 7 using the “legacy” rhino render

you are correct that v5 did not have the raytraced display mode

For those who have access to Raytraced and you need to get vertex colors visible you can use a hidden material by running the command TestShowPrivateContent, then add a Cycles Vertex Color material and assing that to the object with vertex colors. It should now render with Raytraced and from Rhino 7 onward with Rhino Render as well.