Texture Mapping tiles randomly

I’m trying to apply a .png satellite photo over a surface, but I get a weird result, the image just tiles randomly. I tried making a mesh out of that surface and still get a similar result, as per the screenshot. My workflow was as follows:
Texture Mapping --> Apply Surface Mapping --> Bounding Box over the surface I need, duplicated the curves forming a rectangle --> UV Editor --> Use Texture --> Bitmap --> .png

Hello - use a planar map here, I would say - it looks like what you have is a polysurface, and not a surface.


Or could it be that there is intersecting geometry? Looks like one object got the texture and an other object is still default white. Try _seldup or check the scene could help.

Cool, that worked. However, the texture dissappears whenever I click “Apply”? I don’t see it in rendered mode neither in shaded?

I applied it as a material instead and it worked, but at the cost of being unable to transform it along the surface like you could with texture mapping :frowning:

Hello - I am not sure exactly what you mean but you can turn on the mapping ‘widget’ in the object properties and manipulate the projecting plane…?


Here I expected “Apply planar mapping” and not Surface. Maybe this is the reason for the problem.

Don’t recall what I did, but I think I solved it. However one issue persists. Whenever I try to apply a bitmap texture to an object, I can see it in preview, but once I click “Apply” in UV Editor, it disappears and I cannot see it neither in rendered neither in shaded.

Hello - is this the case with any object - just a plane for example?

Please run the SystemInfo command in Rhino and copy/paste the results here.


Yes, even the plane :frowning: As I mentioned earlier, it seems to only occasionally work when you click “use material” instead of “use texture” in the UV editor. Here are the specs:

Rhino 6 SR19 2019-10-22 (Rhino 6, 6.19.19295.01001, Git hash:master @ 0af62045bd35259d4c2367dbf7f9ef94ded29299)
License type: Commercial, build 2019-10-22
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Hybrid graphics system.
Primary display: Intel® HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 9-29-2016 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 860M (NVidia) Memory: 2GB, Driver date: 12-24-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.87

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-24-2019
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.19.19295.1001
C:\Program Files\Geometry Gym\Rhino3d\BullAnt.rhp “bullant”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\User\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.12.17.906\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

That old under powered Intel 4600 chip does not support the bitmap viewing in Any working display mode. It should show in an actual Rendering.
Can you switch the “Primary” display to the GeForce card?

Also, I’d update the drivers for both cards.
Your Notifications Panel has probably been asking you to update them for a couple years now.