Lines are not visible?

I just started Rhino 6 and when drawing lines/rectangles/etc. none of them are visible unless I select them (when I disselect them they are again not visible). Also when extruding a surface into a solid object it’s not visible in Wireframe Mode but in Shaded Mode for example it’s visible (lines are not visible in any mode). Is there a specific setting I need to change?

Hi @ines.loimayer,

Could you paste the text output from Help -> System Information... ? There is a chance the GPU driver is not up to date.

If updating drivers doesn’t fix the problem, go to Tools -> Options... -> View -> OpenGL and un-check GPU Tessellation. Does that fix the problem?

-David

1 Like

Hey David! It worked with un-checking GPU Tessellation, thanks a lot!!!

1 Like

While that might help, you will be missing out on much of the display improvements that were made for RH6!
Please post your SystemInfo.

Hi David

I have the same problem,
the un-check GPU Tessellation helps but maybe that the “real problem” can be fixed with the system information:

Rhino 6 SR2 2018-3-6 (Rhino 6, 6.2.18065.11031, Git hash:master @ cd4fa1dcdec31cb58baacef0855771173af7196f)

Windows 8.1 (Physical RAM: 16Gb)

Quadro K1100M/PCIe/SSE2 (OpenGL ver:4.4.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.4
Shading Language: 4.40 NVIDIA via Cg compiler
Driver Date: NA
Driver Version: NA
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 128 MB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Even thought driver date says NA, I would suspect that the driver is old due to the Render Version of 4.4. I would try updating your nvidia display driver.

we just switched over to 6…

I’m working on a bunch of layouts that have about 20 pages going right now. Not sure if it has something to do with THAT but all I have in model space are curves. I have another file that has my actual 3d models in it… anyway, all my lines and drawings have completely dissapeared and for some reason my titleblocks are all not showing up. When I select them, I can see them highlighted? I tried to change the display colors etc, refreshshade just because, not sure whats going on - scared to close my file… cannot show you guys the file, sorry

unchecking open gl does not work

system info here
Rhino 6 SR15 2019-6-13 (Rhino 6, 6.15.19164.21011, Git hash:master @ e41c99d36bb5000377057645e96b3ea6facf6171)
License type: Commercial, build 2019-06-13
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: CC826

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro M4000 (NVidia) Memory: 8GB, Driver date: 3-16-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 391.25

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-16-2018
Driver Version: 23.21.13.9125
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\export_PDF.rhp “PDF Export” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users\DanKer\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2019.2.19.478\SectionTools.rhp “SectionTools”

Hello - if you Zoom Extents in model space, does the view look as expected (Assuming you select all to make it highlight) or is it zoomed way out?

-Pascal

it works as expected with zoom extents… only a few lines visible, everything else completely gone!

i can highlight it all…

tried _4view, my first thought was that it was a clippling plane, but no

That driver is more than a year old. It’s suspect.
In the Panels pull-down, open Notifications,
Do you see a warning to update your Quadro display drivers?

I doubt this is a driver issue if your regular modelling views are working as expected.

Is there anything you can send us even privately?

I was in shock my driver was that old, didn’t even notice that.

Looks like it’s working great, thank you all.

@pascal @John_Brock CRAZY but it DID IT AGAIN?!?! pretty nervous at this point

Hi - can you make the issue appear if you start a new file from a factory-default template and add some curves and layouts?

If that is not the case, can you simplify the file you are having issues with so that you can still reproduce it and upload it on https://www.rhino3d.com/upload? Make sure to include a link to this thread in the comments field.
-wim

Hi Wim, @stevebaer

Yea I can’t show this file unfortunately.

The only thing that works for me is save>close. Reopen. Ill be working on it for a few hours and then it all disappears. Like I said, there are no actual 3d models in this file. Just curves, make 2d, oldschool style. Everything next to 0,0,0

Lots of layout pages and lots of detail viewports. I feel like this is the issue?

Is there a way for me to reduce the file? to give you an idea, my LINES ONLY SHEET FILE is 550,450 kb … my model is only 386,350 and that has extra stuff I don’t need in there…

Since I can’t see the model, I can only start making guesses.

Maybe there is some bad geometry in the model that is causing incorrect bounding box calculations. Try selecting everything in the model and run BoundingBox. Do you get a bounding box that you expect or does it look incorrect?

HEH there was actually a bad object but it was a curve since there is no 3d geometry in this file. All just 2d linework. I was sure that was going to fix it, but it’s still doing it… :frowning:

Does it look something like this?

'Cause this is still happening.

@Asterisk are you able to still highlight the objects — as if they are still there but you just cannot see them?? because if so, than YES