Text command

Currently trying to run the text command and hitting a road block that brings up some fundamental UI issues.

It used to be that Text brought up the insertion point first to pick location, then the dialogue box. I liked this a whole lot better as could see how my text was going to fit in the model space while typing, rather than after typing. Anyway, this has now been switched to dialogue box first, then type, then click ok, then insertion point, then choose location. Fine, different. But my point lies in an oddity found when using a different monitor setup. I ran the text command and then nothing happened. The command line looks like the command has just disappeared like nothing is happening, and there is no dialogue box. Command not working. What I really think is happening is the dialogue box is not appearing on my screen because of the monitor setup, but the command line really should show that a command is in process. It shouldn’t appear that literally nothing is happening at all. Am I missing something here?

Hello - just to be sure - by this do you mean that the dialog is on a second screen and you did not notice it right away ( assume), or that the dialog was completely off any screen?


When restarting the command is working once, and then after that it won’t work again. Which I am assuming is the dialogue box not being visible. It is completely off any screen. I tried again turning off and disabling the second monitor still no luck.

Hello - are you restarting Rhino and or Windows when changing the monitor setup?


Did not restart Rhino when I changed the monitor. But since posting I updated Rhino and it seems to be working. But I would like to note that I still think the UI is misbehaving when there is no indication in the command line that there is an active command running.