Sweep one and sweep two rails

Good evening I am trying to make a heart but:
with “sweep one rail” getting two errors (at least) as per attached photo
With “sweep two rails” I can not continue, that is I do not get any polysurface.
I attach also the file.
Thanks for the help.
Mirco


heart rhino.3dm (6.3 MB)

1 Like

you could split the surface before the sharp corners, the mirror the half to make two identical sides and make a blendsrf in between:
image
heart rhino_blendsrf.3dm (910.0 KB)

1 Like

you can also check out Plugin Update v1.1.0: Pipe Corner Clean

2 Likes

Thank you very much I’ll try

Thank you again, but if the heart rings are two and twisted together how can I fix it?
I mean I can not do that.
thank you. I enclose rhino file
heart rhino.3dm (14.8 MB)
Mirco

Hi Mirco -

Why not? I’m not sure I follow - ExtractSrf the surface, cut it up and delete the self intersection, BlendSrf to fill the gap and then Join it all up again -

image

-Pascal

1 Like

Thank you Pascal, I’m going to try later today. You are a very helpful source!!! Thanksssss,. Mirco

Dear Pascal I have tried to ExtractSrf but it does not work.
So I have tried ExtractWireframe (pict.1), I cut and delate self-intersection and made BlendSrf (pict.2) and it does not come: you can see in the prospective view
However. Plus my pop up box i can not see: “interior shapes” which, besides, you click. thank you for you help

Hello - use Split > Isocurve (Direction=V) on that surface after extracting it.

-Pascal

I have now made a major cut and then used the command blendsrf, it seem a bit better but I’m not convinced. Beside I was not able to follow your indications. Plus the curbe is less pronounced while I wanted a more evident curvature. Thank you

major cut.png

Hello - does this help at all?

Use the ‘Natural’ setting when initially aligning the blend.

-Pascal

Thank you Pascal, I’ll try later today!:grinning:

I did it!!! Thank youuooooo so much

1 Like