Sup open-polysurfaces

Hello, community. I’m trying to use Sweep1 ( to spin an open curve around a closed one) to get a desired shaped object, and I got it (an open Polysurface). At a glance, it seems like one whole Polysurface but when I click Shift+Ctrl+LMB it consists of four sub-Polysurfaces. I want it to be an entire Polysurface since I want to create UV curves from that Polysurface.
Of course, I can create the desired object in other ways, but I wonder what causes this separation when I use a Sweep1 tool. Any suggestions?
Thank you.
Sweep1_sm.3dm (224.1 KB)

I believe it is because your rail is degree 2. If you tick the Refit rail option in Sweep1 you should get a single surface. Better, if you rebuild the rail to degree 3 first you will get a single surface without needing to tick the Refit option, and it will be simpler than the surface from the refit approach.


Hello - I would just make a Revolve here, I think.


Hi Jeremy,
I tried both the methods you pointed out and, both of them worked well. There was only a slight difference in the Isocurves. I got a much clearer surface when I used the revolve command as Pascal mentioned below.
Thank you.

Thank you, Pascal.
It worked well.

Check out RailRevolve too if you are not familiar with it :slight_smile:

Another handy tool. What I like most in Rhino is that we can approach things in many different ways to get the very same result. We are not limited to a single tool. Being a little creative is a must )).
Thx Holo.

1 Like