Surface won't export in Revit

So I’m trying to export my file from rhino (.sat) to revit and everytime I save it in rhino it says that meshes can’t be exported. As far as I know, I don’t have meshes in my rhino file. When I click the surface that didn’t export in rhino it says on the top “polysurface” and not “mesh”. How do I fix this problem?! EDIT: for some reason, the image from rhino is not showing unless you click the link above the revit image

can you upload that portion of file? I think it have edge problems

Here is the rhino file
Refined bldg idea.3dm (3.5 MB)

which profile are you using to export from Rhino?

what do you mean by profile?

which of those options do you use?
I don’t have Revit and I don’t use that format so I don’t know the cause.
when I use the Default option, it says it doesn’t support curves. but nothing about meshes.
also you have a self intersecting surface at the bottom of the object. I don’t know if that’s another problem.

I exported it as AutoCAD. That’s when it says meshes cant be exported. When I tried default, it said it doesn’t support curves. Ignore the self intersecting surface, it’s irrelevant to my project

the file you upload doesn’t have meshes, try with the command _SelMesh maybe you have some tiny meshes around in the original file.

Revit is very selective about its Freeform surfaces. In this model there are a number of surfaces that are much more complicated then they need to be. For instance with Planar curves, the Planar Surface command is a better command then using the Patch command.

Using Rhino.Inside.Revit and using the Sample 8 button in the Revit toolbar I get this. It brings in the shapes. But many of the shapes are meshed because the surfaces structures are more complicated then they need to be.

Where did the original curves or model come from? With continuing to rebuild and clean up surface structures the resulting model could all be freeform surfaces.

Refined bldg idea_sd.3dm (3.5 MB)


Thanks Scott! This is exactly what I need. I tried to use the rebuild command but for some reason, it won’t let me. I had some edge problems as well. The curves originally started as one curve but I had to split it up eventually to make and control the surfaces, that’s why I ended up with a very complicated polysurface.

The complicated part of the shape is a polysurface, so a simple rebuild is not enough for those. Making to original curves simple and then using math surface to get smooth transitions will be the trick.

You may want to send the curves and the curved part of the model to and they may be able to help a bit.

Going through some of the surface modeling tutorials might help too. There are many design variables you are trying to work with here.