Surface Book 2 fan gets loud as soon as I start Rhino

The fan in my Surface book 2 gets loud as soon as I start Rhino 5. I’m wondering if there are any settings that need to be changed in Rhino, or in my computer to fix this problem

I’d guess that it is switching to the higher performing Nvidia graphics processor which will generate more heat. On the original Surface Book you see a little lighting bolt in a circle appear in the dock/undock control in the Windows toolbar when this happens.

That said, my original Surface Book needed me to add Rhino to the list of programs that automatically switch to Nvidia.

@raniat123, all all - something like this has come up a few times and it appears there is a solution, outlined here:


@pascal, I don’t know about the Surface Book 2, but on the original Book the NVidia Control Panel is crippled so you don’t get any options other than which card to associate with programs…

I see, thanks. I’m not sure what the way out is - in other contexts we’ve also recommended the ‘prefer high performance’ setting, which seems to be the cause of the extra GPU churn.


I see the high clock rates in GPU-Z on the Book but I don’t find the fans get irritating - may be just that I’m old and deaf or there may be something about the Book’s power management that is different.

But the Book 2 is a big step up in CUDA cores from the Book so it presumably has a lot more heat to contend with.