Suggestions for ApplyEdgeSoftening workaround?

Hi all,

For some reason, ApplyEdgeSoftening isn’t working on my model. It’s not especially complex, but I guess it’s enough to throw Rhino off-course.

Does anyone have any suggestions to imitate this? I need to extract the render mesh, as it’s going to be printed and they want the printed part to resemble a tumbled, worn-down part.


Hi Declan,

How is edgesoftening not working?
I believe setting up a custom meshing can make edgesoftening work better.

As for the tumbled worn-down look,
How about this:

first mesh with a setting that created evenly sized mesh faces

Next run smooth on the mesh, you will need to experiment with the settings and number of itterations.
Maybe you need to remesh at smaller sizes to get a less course wearing-off.
Note that I welded the mesh at 180 degrees to get this look.

If needed you can run reduce mesh afterwards to get rid of an overkill of mesh faces:


Hi Willem, Declan- keep in mind that welding has no effect on the mesh facets, nor on the results in 3d printing- it is much more useful to look at the mesh under FlatShade in this context.


Could you send the model to so we can test?

Content-Type: multipart/alternative; boundary=“1844268657-1120270840-1384363778=:35990”

Content-Type: text/plain; charset=us-ascii

Hi Andy,

File attached.




It didn’t like it! Can you do it by email - it’s more likely to get through that way.

  • Andy

Hi Pascal,

Thanks, Yes indeed this was for looks only. Yet I wanted to make a note of it as the initial look would be like this:

I had welded it without thinking and did not want to confuse by omitting that step.