Polygon Tweaking - Workaround?


#1

Hey Rhino-Cracks! just welded an entire mesh. Despite of that I have not just one vertex but all overlapping vertices selectable. To speed things up in my polygonal furniture work is there a way to deal with verts the same way as in all common poly modelers? Is there probably an enhancing plugin for mesh work in Rhino, that I’ve not discovered yet
Working out a consumer product version of my Mirror Table (s.b.)

thanks in a lot! Hannes


#2

hey Hannes, this object is geometrically very simple, to get the best working with it further you could use MeshToNURB and work it will all available nurbs tools from rhino. what are your further steps on it?

mesh tools are very limited but still cover the most basics i would say, even including Smooth maybe try that on your model just for fun you might have to use it a few times to round it up but that would go into another direction.


#3

Does _WeldVertices do anything for you? --Mitch


#4

@Helvetosaur Mitch you are my hero! Thanks a bunch, but how do I get the shadowing away (looks like the weird vertex maps from Modo)

2nd last question: “Near” Osnap somehow doesn’t work on mesh edges, is there a way to turn it on? Have always DuplicateEdge first to get this working on the resulting curve…

Thanks! H


#5

try FlatShade the same command can also activate it again if am not mistaken.
and Vertex Snap is the only snapping available for mesh as it seems, but that should do?

i assumed you welded the entire mesh successfully hence my suggestions :smiley: sorry for that.
nurbing it still can give you some more tools. but ok it might suffice so either.


#6

Yeah, welding the mesh vertices will do that - normally I would say to use Unweld 0, but then you will be stuck with your multiple vertices again. So setting your display to FlatShade is probably the only way to go here. As Richard said, in this case you could also MeshToNurb and work with surfaces - there are very few facets to worry about.

You cannot snap to anything other than mesh vertices in V5. I thought they were going to add at least mid to mesh edges for V6, but doesn’t look like it’s happening yet.

–Mitch


#7

@RichardZ thanks so much, this helps me a bunch finding a proper workaround for my process… Would come also handy when working further on my www.dezeen.com/2009/01/08/cozy-furniture-by-hannes-grebin/ more to come!


#8

Will work now as mentioned in my recent ClippingPlane post as switching/converting from mesh to Nurbs and back for full controll. Yeah and concerning Serengeti I posted after my first view, that I’m a bit sad, that they wouldn’t concentrate on a mesh/NURBS workflow more and getting more sophisticated mesh workflow since I believe the working in Nurbs and SubD meshes back and forth will be the future as it’s damn smart and fast.


(Pascal Golay) #9

Hi Mitch - snapping to mesh edges is in place in the WIP but you need to turn it on - SnapToMeshes.

-Pascal


(Kyle Houchens) #10

also don’t forget the “between” modifier for moving stuff… helpful for going to the middle between 2 points-

type move, pick the move from location, then type “between” in the command line (no quotes) and pick the two points you want to bisect, enter-