Stuttering rotations while moving cursor on viewport

Hi all.

I’ve just updated rhino 6 to latest update, and i’ve realized the viewport rotation is no longer smooth.
Maybe the problem was already there, but making the update made my eye more severe towards any imperfections…
Also, as my other thread here Mouse 3d not working properly , lowering the pooling rate to 125Hz was enough to fix the problem.
Now is no longer.

My G502 mouse, or any other mouse i use (3 tested), trigger again the problem:
while the 3d world is rotated by the 3dconnexion spacemouse, if i move the cursor over the rhino viewport, the framerate drop to 3-4 fps, if not completely freeze!
The 2 mouses almost can’t be used toghether!

Also, I’ve noticed the rotation of the 3dconnexion alone is not smooth: with a static input the rhino world rotate at an incostant rate, stuttering.
I’ve installed 3dconnexion driver+software, but this fix this second problem only partially, and button menu is replaced with a less useful one, without the camera/object mode.

Rhino 5 on the same machine have none of this problems.
On rhino 7 wip everything is pretty much the same as in rhino 6.
Exact same results on a completely different machine.

1 Like

Managed to capture the problem on a gif, even though the problem is much more evident while the gif software is not running, no idea why…

Moving the mouse cursor while rotating the view with the 3d mouse:
wireframe: stuttering
shaded mode: smooth
wireframe while selecting: smooth
stuttering

Any ideas?
This is driving me insane.
The advantage of the 3d mouse is, also, to rotate the view while you do something else with the “2d mouse” …

Edit:
This is with rhino turntable function. Moving the cursor make the animation stutter.
So i suspect the problem is not related to the 3d mouse directly.
I can replicate this on 2 other machines. (no 3d mouse connected, any mouse/trackpad do the same)
turntable stuttering
Sometime it seems that it doesn’t happen, but after insisting for some second it start again to stutter.

Can anybody else replicate this behavior?

1 Like

@stevebaer this looks like something related with display performance. Regression from 5.

It’s a well known problem since the days of Rhino 5 many years ago. For some reason, the 3d Connexion devices and Rhino don’t work smoothly together if the report rate of the regular mouse is above 125 reports per second. Rhino 5 worked just fine even with 250 rps. However, Rhino 6 experiences shutters at 250 rps and the only solution is to go down to 125 rps for the regular mouse. It happened with various mice by several manufacturers, so it’s definitely not related to a specific mouse model or brand.

By the way, I also use Logitech G502 and noticed that DPI 2000 at 1000 rps (my preferred way to use it) has an equal speed to DPI 1300 at 125 rps. Interesting, huh? :slight_smile:
Actually, at 1300 DPI and 125 rps the mouse pointer is just slightly faster, but since the Logitech software won’t let me use a custom resolution like 1285, 1300 is the closest to resemble DPI 2000 at 1000 rps. DPI 1250 at 125 rps is noticeably slower than DPI 2000 at 1000 rps.

I haven’t been able to reproduce this issue here with a 3D connexion navigator running 3DxWare 10.5.15 and Rhino 6.25 for Windows. Here are some thing’s I’d check based on what you reported.

  1. Are you using the recommend Windows display scaling setting for your monitor?
  2. Have you updated your Radeon GPU driver since the one you had from May 2019 in the system info on your other post?
  3. Are you using any additional monitors of perhaps different resolutions?
  4. On the systems with no 3D mouse plugged in that you also reproduced this on, are there any common hardware elements or settings?
  5. Does this happen on the systems without the 3D connexion mouse plugged in and Rhino restarted?
  1. Yes, “100%” recommended scaling.
  2. Yes, current driver is latest “Radeon Software” release.
  3. Single monitor.
  4. I reproduced the problem on 2 laptops using the trackpad, nothing connected.
  5. Yes, i can see the problem on machines that have never been connected to a 3dconnexion mouse, by using the turntable function.

On a laptop running on a i5-8350U APU, moving cursor via trackpad almost completely stops turntable animation.
Same laptop, using a mouse, the stuttering is less (but still very present).

I have no idea of what is going on, but the DPI or Hz of the cursor surely affect the problem, as stated also by @Rhino_Bulgaria and my other old post.
If I set my G502 to 1000Hz, rhino viewport totally freeze until i stop the cursor.


Just found out this:
Moving cursor outside any viewport (but still inside rhino windows) actually speed up turntable. :upside_down_face:

Edit: moving the cursor over the ui make the Properties tab itself stutter (updating camera+target less often) and that makes turntable run more freely.
Closing properties tab let turntable run “faster” (aka correctly normal) all the time, moving the cursor in ui make no difference.

1 Like

Looks like you just invented a free graphics accelerator. :innocent:

Thanks for the additional details. Can you supply the SystemInfo command results from a laptop without a 3D connexion device that shows this problem please? Also include the make and model of your mouse and the driver/software version for it as well as any settings you’re using in that app. I can try and find similar hardware to see if we can reproduce this to file a bug report. In your GIFs you appear to show this happening with the use of a 3D connexion device and also during Turntable. Neither cause this issue here so far so I think it’s some combination of hardware and software drivers and Rhino 6.

As a test, can you also try disabling GPU tessellation in Options>View>OpenGL please? If this also only started after the 6.25 update, can you check Windows updates as well? They may help especially if the GPU driver was updated recently.

The mouses i’m using in this last tests are: a Dell N889, a Tecknet BM308 , a Logitech G502 and 2 built-in trackpad.
All of them are using a generic 2006 driver from Microsoft, version 10.0.18362.1

Laptop1_systeminfo.txt (1.9 KB) Laptop2_systeminfo.txt (1.6 KB)

GPU drivers are updated, from what i see. GPU tessellation on/off make no difference. (restarting rhino)

No, this problem is not new.
It’s worse than in past, my other thread is from 2019 but rhino was never perfect with framerates.
With videogames i’m “used” to see difference from 60 to 120 fps and from a smooth and a stuttering ones.
Rhino _testmaxspeed says something like 550fps, but what i see seems like a “dirty” 45fps, because of the small stuttering here and then.
I’m not trying to offend anyone’s work, just reporting :no_mouth:


Now that we are here, let’s dance:


I see small details like this every second using rhino.
Slow-motion video of turntable.
In the first seconds the cursor is standing still, framerate is not “stuttering” but still having small “hiccups”, like a small pause every 4/5 frames.
At 0:14 i start moving the cursor (outside viewport but in rhino): no more hiccups!!

All of what i’m reporting is from a mix of 5-6 machines (if i include the ones in my last employement)… in my ignorance i would exclude drivers, as every other software is working good so far… but you are the experts.

On laptop 2 with the Nividia GPU, your driver is from 2015. Use the Notifications panel from the Panel drop down menu in Rhino 6 to get a link for updating that driver. See if that helps on that laptop please.

Laptop 1 has an Intel HD 620 GPU which is not great for Rhino 6. I don’t know if that is part of the issue on that machine but I would guess it can’t handle the requirements of Rhino 6’s display.

You also mentioned some generic drivers from Microsoft for the mice you’re using. Have you installed drivers from the mouse manufacturers instead like Logitech?

My Laptop2 is from 2006, working flawlessly with anything i’ve tried, rhino included if not this small detail. That is the most recent driver for such old card.
Laptop1, not a workstation but sill modern, an empty rhino file should have no performance problem.
Logitech driver is installed, latest version. What i did report is the driver on device manager.

I remember rhino 4 handling 30MB files with no stuttering at all, on any machine.
(with pixel-perfect curves Graphic bugs in rhino 6 and 60fps)

Now with rhino 6/7 I’m having stuttering on any machine with empty files.

I’ve just reinstalled the whole OS on a new SSD with official drivers for all my hardware: same exact problem.
My Ryzen 1800x + RX 580 system is not having problem on any of the other software i’m using, just rhino.

I think that focusing on drivers is not the solution here.
I think OpenGL engine of current Rhino is degenerating over time.


I don’t know what to do to report more, I can replicate the problem on any machine so far. I would test further on other machines but i still refrain from moving too much in this times.

Rhino 5 was better, i bought rhino 6 and use it everyday, but i’ll be really upset to buy rhino 7 knowing the situation is worsening.

If you hide the status bar, does the stuttering go away? I know we constantly try to update the status bar while the mouse is moving on viewports. If the stuttering goes away, this would help us understand what is causing this problem

3 Likes

I can confirm that shuttering and freezing disappears once the status bar is being hidden.
Rhino 6 evaluation on a laptop Acer Aspire 7 with Intel Core i5-8300H, Nvidia GTX1050 4GB with latest video drivers and Windows 10 Pro. Maybe it’s a good idea to lower the frequency at which the status bar reports the current coordinates to prevent shuttering in the future? People really don’t need tens of reports per second for this. I think that fixed rate at 5-10 times per second is still a good frequency.

Shuttering happens both, with the mouse trackpad and a Logitech G502 mouse. The only alternative way to get rid of the shuttering is to go to the Logitech gaming software and lower the report rate to 125 reports per second.
Several years ago when I was working in another country, shuttering was present on Rhino 5 on a desktop PC with Ryzen processor and GTX1070, so I suppose it’s not limited to just Rhino 6.

Cheers,

Bobi

Stuttering gone!
I can even use the 1000Hz option on the logitech G502!
Tested on 3, machines. That’s it.

If i disable also the “Properties” tab, which contains camera and target location (that are displayed in real-time as in the status bar), turntable spin at 3x speed!

Disabling both make everything very smooth. Much smoother than everyday usage i remember so long.

Disabling only status bar, makes a turntable animation move faster if the cursor is moved over the ui.

GhGl animations have still some small stuttering (that can be “fixed” by continuously moving the cursor over the ui)…

NICE!!!
Love you!

All - I’ve written “something” down for this issue - RH-58680.
Trying to read through this thread, it appears that whenever the viewport camera rotates (either by using a 3D mouse or by running the Turntable command), any mouse movement inside the viewport area will cause stuttering. I’m not sure if that’s a correct interpretation of what was reported here.

I can reproduce this on my system but what makes me unsure if it’s the same behavior is that (1) the viewport rotation stops completely (i.e. no stuttering), and, (2) turning off the status bar does not help.
-wim

1 Like

hmm… i described it wrong, more like it “pauses” completely, but while using a 1000Hz mouse.
Same mouse at 125Hz setting does the normal “stutter”.

Have you tried disabling also Properties tab?

I have a good situation only by disabling both, status bar and Properties tab.

Yes, my Properties panel was not open when I tested this.
-wim

Turning on “Rhino Options > Modeling aids > Cursor tooltips > Point” also causes micro freezing while trying to snap an object, because the tooltip renders the current coordinate whose very high refresh rate probably conflicts with the mouse’s report rate.

The freezing is extreme (Rhino basically freezes for 5-10 seconds) while trying to snap on a scanned 3d model with millions of triangles while using any shaded view mode, no matter if the report rate of the G502 mouse is 125 rps or 1000 rps. There is no freezing on such complex mesh models only if using Wireframe mode.

And another small detail:
If 3dconnexion plugin is active (with or without 3dware installed) and 3dmouse connected (but untouched),
(GPU tesselation and AA on/off , no difference. Status bar and Properties tab off.)
i can get a “perfectly smooth” turntable animation only when mouse click is pressed:


Small pause every 4-5 frame, seen better when slowmotion starts at 00:07

Shaded viewport, 40 lines and 400 simple surfaces.geometries.3dm (1.2 MB)
With no objects the problem is not visible.

Instead, rotating with 3dconnexion give small “hiccups” regardless of what i try.

I can continue reporting small details like this, but it would be an overkill for now.
It seems that anything that interact with the viewport actually also interfere with the viewport.

For now i’m glad that disabling status bar and Properties tab let me work.
I’m hyping for an official solution.