Strange gumball behavior


#1

Most of the time when I click on an object the gumball flashes (appears for a microsecond) and then disappears. To make it reappear, I have to zoom in or zoom out from the object (with the mouse wheel) – then it reappears and stays so I can use it.

Just wondering… is this a normal part of 3d modeling or do I have some kind of setting that I need to adjust?

Does anyone else encounter this?

(I am running Rhino 5 with Windows 7 – 16 gb ram)


(Brian James) #2

Hi Cosmas,

That sounds like a display error and shouldn’t happen. Can you check if there are any updates to your graphics card driver and also make sure you’re on the latest Rhino service release ( http://www.rhino3d.com/download/rhino/5.0/sr )? I have also seen this on occasion but not often and have not been able to reproduce it for a bug report yet. If you have a model and set of selection steps that cause it, let me know please and I’ll see about getting it looked at by the developers. If the GPU driver update and being on SR6 doesn’t help, please let me know.


#3

Hi Brian,

Both my graphics card and my Rhino are up to date (Rhino is at SR7). I wonder what could be causing this. What’s interesting is that noone else seems to have responded to this. Maybe it’s just a glich with my computer.

To answer your question about a pattern – there really isn’t one. It just basically always happens. Whenever I click on an object, I have to zoom in or out to get the gumball to “stay.”

Thank you…


(Pascal Golay) #4

Hi Cosmas - does the gumball stay if you zoom Extents or Zoom selected?

-Pascal


#5

Hi Pascal,

It’s interesting that no one else has come forward with a similar problem.
What happens is that I click on an object, and instead of having the gumball appear, it flashes on and immediately disappears. This also happens if I marquee sweep an object.
If I zoom in or out (by rolling my mouse wheel) it comes back on and stays. If I run zoom extents it also comes back on and stays.

  1. Happens in both Layout space and Model space.
  2. I’ve got Gumball on (via the button at the bottom of the screen).
    I checked my graphics card and it is up to date. I tried adjusting my mouse settings and that did not seem to help.
    Any ideas? Is this just a common thing with 3d modeling and should I “grin and bear it”? – or is it worth chasing down?

Thank you.

Cosmas


(Pascal Golay) #6

Hi Cosmas- if you zoom extents, are the camera coordinates reasonable (Properties panel, with no selection)

-Pascal


#7

They seem to be…


#8

I can confirm this. Been here from SR4, though it happens randomly.


#9

Curious whether this sounds like a hardware issue or software? I have the following hardware configuration:

Computer: Boxx G1840
16gb ram
Nvidia GeForce 675M
Intel Core i7-3720 QM Quad Core Processor

@cadmaster do you have any of the above?


(Pascal Golay) #10

@mikko, @jeff, does either of you guys have an idea about this?

thanks,

-Pascal


#11

QuadCore AMD Phenom II X4 Black Edition 960T, 3400 MHz (17 x 200)
AMD Radeon HD 6850 256bit (1 GB)
8GB RAM


(Jeff Lasor) #12

I highly doubt this is a graphics hardware issue…and is most likely a bug in Rhino.

I do know of a situation where the gumball disappears when a view loses focus (or gains focus)…and I’m not yet sure why that is. For example, simply clicking on the view’s title bar can cause focus messages to get sent through the system, and the gumball disappears.

Now, as for why you’re seeing a similar issue without doing anything is even more of a mystery.

Do you have any other kind of hardware attached to your system that could be stealing focus? For example: A space mouse or other pointing device.

Do you have any kind of capture software running that could be changing focus?

-Jeff


#13

Hi @Jeff,

Interesting. To answer your questions:

  1. Do I have any other kind of hardware that could be stealing focus? No. The only mouse I have is a Razer Death Adder infrared mouse with a cable attached. Nothing else.

  2. Any kind of capture software that could be changing focus. Again – not Just Rhino open on my monitor.

I have to say that I’ve noticed this as far back as a year ago, but didn’t say anything, thinking that maybe it would resolve itself. Then, I decided to post something just to see if I was the only person in the world with this, and I see that there are at least two others: @BrianJ and @Cadmaster. It’s not a big deal, but it does kind of break your stride… as you’re working away and happens, I would say, at least once every couple of minutes, and maybe 1/ 10 times I call on the gumball.


(Pascal Golay) #14

Hi Cosmas- this is a real shot in the dark but does it make any difference if you have Properties open and docked or closed, or floating?

-pascal


#15

Interesting. I’ll try it and get back to you.


#16

@pascal,

I think you may have found it. I previously had the Properties panel docked on the right side of the screen (along with Layers, Notes and Named Views) and I was getting the problem.

An hour ago I pulled it away so it is just floating by itself, and the problem does not seem to be happening. I will keep an eye on it and confirm it at the end of the day.

Interesting.


(Pascal Golay) #17

Hi Cosmas- the developer looking at this left a comment about the docked Properties panel- it seemed worth a try. I will let him now it appears to be a factor in your case.

thanks,

-Pascal


#18

Hi @Pascal,

It’s been two days now and I can unequivocally say that the gumball works perfectly when the Properties panel is in a floating position.

Interesting.

Thank you.


(Pascal Golay) #19

Hi Cosmas- thanks for the follow up. I think the developer has at least an idea what might be wrong here, I do not know how fixable this is for SR8.

thanks,

-Pascal