Split Failed, Unsure Why

split
unhandled

(Waffle Man) #1

Hello,
I have been trying to split this model into two halves in Rhino based on Voronoi boundary information. When I tried to extrude two sets of different (joined) curves, it wasn’t working, so I figured that I would try it with just one of the sides. I am still getting this error message, “[s]plit failed, objects may not intersect or intersections may not split object.” I am not sure why this would be giving me trouble. The cutting surfaces seem to be connected (they are joined) to form a polysurface. The only explanation I can come up with is that they are not actually connected somewhere, but I am not sure how to figure out precisely where the problem is. The object splits correctly with a regular 4 point plane. Any suggestions would be greatly appreciated!


#2

Split worked for me (mac though…). What is your unit tolerance set to? May be too fine.
FYI I had to explode the object after it split, and manually select and rejoin the pieces of the two halves.


(Waffle Man) #3

I just tried it again, and I got the same error message. Here are my tolerances. Very bizarre! I appreciate it!!


#4

This is a bit dirty, but if you change your tolerance to 0.1 units, and try again? All I can think of. Also, are you trying a simple split? Or are you running a boolean split command or similar?


(Waffle Man) #5

Just a standard split! I’ll definitely try it. What does the tolerance mean specifically with respect to the Split command?
EDIT: Just tried it. So I will have to rejoin the 1355 pieces manually?


#6

Yes, it seemed to need to be exploded and joined manually… if you do this in front viewport display its not too bad. I’d start by hiding one half, then select all and join… then show, repeat join on the other side.

I don’t know how the tolerance works in detail- but lowering it from what I understand basically allows rhino to be a little messy but perform operations that otherwise fail. The quality of your surfaces may suffer a little, but in practice I haven’t run across any issues. I’d put the tolerance back to 0.001 after you perform the split operation at any rate.


(Waffle Man) #7

Thank you so much!! I’ll give it a go for sure later tonight or tomorrow


#8

You do realize, don’t you, that you can just box-select all 1355 pieces (or any subset of them) and put them all back together with one join? Or use a combination of box select and individual selection to add or subtract objects from the selected set.


(Waffle Man) #9

I thought I would give that a try, but was not sure that it would work. Thanks!!


(Waffle Man) #10

I am still getting the Split failed error when I try with surfaces generated on both of the sides. Any help would be greatly appreciated
EDIT: It still works when I split it with the flat plane though


(Pascal Golay) #11

Hello- in the file you posted above, if you hide or delete the curves and then Intersect the two objects, then use SelOpenCrv you’ll see where there is a problem. It looks like one of the faces does not intersect properly with the cutter - I’ll see if I can figure out what is going wrong - looks a bit buggy to me.

-Pascal


(Waffle Man) #12

Thanks a lot – I don’t quite understand what you mean, but it definitely does not surprise me that something is massively wrong.


(Waffle Man) #13

It doesn’t make sense to me that the polysurface wouldn’t be able to split it. Ultimately, I want to break the object into two halves along edges from the voronoi diagram

EDIT: I am getting the same problem when I went back in to the original form and tried to use an extruded isocurve on both sides to split the geometry. This also happens just using a single isocurve extruded across the width of the whole geometry


(Pascal Golay) #14

Hello - the problem is that in a couple of places intersection falls right on a face edge of the object or the cutter. That condition is a tough one for the intersections tools… I don’t see a clean way out of this one, with such a complex object - an ugly way out is to ExtractSrf that one face where the intersection does not want to complete and then split and deal with the one face on its own.

SplitFailed_PG.zip (7.0 MB)

-Pascal


(Waffle Man) #15

Thanks a lot! I ended up just exploding it and then splitting it, which actually worked. I guess I’ll try to manually join them afterward. I really appreciate the help!