Struggling with Split and Boolean Split

I’m trying to split a closed Polysurface model. It has to be split many times as shown by the split lines. Some of the splits work and some don’t and I don’t understand why. I’ve tried doing boolean split with a surface also, and they fail on the same vertical lines (haven’t checked them all though). The polysurface is basically an outer and inner surface joined at the upper edges. I do this quite a bit with models (for CNC manufacture) and normally the same construction (outer and inner skins) but this one isn’t doing what I’d expect. Is there a simple explanation for this? Or something wrong with the model?

Many thanks


what units are you modelling in?

do you have enough tolerances/floating points?

splits and other commands can fail if the model is not clean or the tolerance is not high enough.

Thanks for quick reply. I did change the tolerance earlier. It is modelled in mm, with a tolerance of 0.1mm. Model overall length is about 2400mm.

Anyway, just tried again with tolerance of 1mm and it is better - at least with splits - Boolean split still not working at this tolerance), so I guess that’s the way to go. Ultimately that tolerance (if reflected in that sort of error) wouldn’t be acceptable, but I will play around with it. I suspect the model is the problem but not sure what’s wrong with it or how to fix.

Thanks again


I think 0.1mm would be what you need at least considering the scale of the object.

Problem is, once you modelled it won’t help much to increase the tolerances.
The geometry is already parametrized at the coarse level.

but you actually went to 1mm? so you lowered the tolerance?

maybe put them back to 0.1 mm and recreate the surfaces from the (maybe rebuild/refit) edge curves. shouldn’t take too long.

on a side note, I guess you are not working a kilometer from the world top origin… because that can also impact floating point calculations

Only way to tell is to post the model here…

After a detailed look at some weird effects, I think I’ve figured out what is causing this. The designer appears to have put 2 coincident polysurfaces together (they just look like 1) and this really screws everything up. I asked him to check if this is possible, but certainly when I found and deleted one of them (both inside and out), it worked fine - with normal tolerances.

Thanks for your collective help