I cant split surface

i want to split this model from the topography but split doesnt work neither do anyother commans, i think its because of the surfaces i have from the model but i dont know how to fix it, can anyone help me. Thanks.

This is the error: Split failed, objects may not intersect or intersections may not split object.


A guess, and only a guess, is are trying to split with suface which is coincident or almost coincident with the surface to be split.

It would be helpful to anyone who tries to help if you could upload a .3dm file with the object you are trying to split and the splitting object. You can use Export to create a file with just those objects.

split.3dm (6.3 MB)
yes i couldnt upload it because of the size, if you could maybe tak a quick look at it, i didnt fully understand what you replied.

anyway thank you for the response

When two surfaces are coincident part or all of the surfaces are in the same place. Split and BooleanSplit frequently fail in that situation.

Your absolute tolerance is 0.01. Some of the details of your objects have a size of 0.01 or smaller. The absolute tolerance needs to be an order of magnitude or smaller (1/10 the size or smaller) than the smallest detail of the objects. The absolute tolerance should also be between 0.01 and 0.0001. Setting the absolute tolerance to 0.001 or 0.0001 may solve the problem. However it not good practice to make the absolute tolerance smaller while modeling.

pull relevant curves using dupedge, then extract surfaces that need to be split, then use said curves to split said surfaces, then rejoin all surfaces.

if any part of your polysurface does not intersect any part of your other polysurface to make a closed area, the split, boolean or trim will fail.

want to see where the part is failing? run the intersect command then select the resulting curve, run the isolate command and inspect the result.

where the curve is open, that’s where the failure will be.

…the more you know (rainbow hands) :slight_smile:

As David mentions, tolerance is the thing here - the entire model is .09 meters or so long and tolerance is .01, that will never work. This should be modeled in millimeters and tolerance .01 or .001. Change this in DocumentProperties and answer Yes to the scaling question, then do your split.

-Pascal