Solved: Not possible to delete layer with an object on it. VisualARQ Bug?

Hi VA Team,

after installing your latest update (and trying to test the new shiny worksession features :slight_smile: ) it seems to be impossible for me to delete layers with objects on them. Also deleting parent layers with sublayers seems to be impossible. The normal pop-up-window with the question if I really want to delete layer with objects on it doesn’t show up and nothing happens.
It seems to be connected to VA because as soon as I switch Tibidabo plugin, everything works as expected again.
Could you have a look at this? Thanks!

Hi @romio82,

VisualARQ disables the deletion of layers used by styles because they are used. This has been the behavior since many versions ago. However, it seems that in the last update, we broke the message asking if you want to delete the layer.

I’m going to fix this now for VisualARQ 2.12.2. As soon as I have a fixed version, I’ll send you a WIP installer.



Hi @enric,
thank you for the fast reply and for looking into this!
Apart from that, it’s great to have worksessions working now! Great work!
I’m trying to find out a way how bigger projects can be divided into multiple part files and worksessioned into one central 2D file where all sections are created. That way, relatively slow interaction in files with many objects could be solved, and having worksessions working is an important step towards a solution in that matter.
Of course it’s a little sad that objects can’t interact across worksessions but I understand the reason and try to work around it.
If I understood you right, maybe linked blocks could be a solution for this issue in a future version? Blocks - or at least the block manager - seem to be a target of action in Rhino 8 anyway as far as the roadmap goes. So maybe one day things will be even easier there?
Thanks a lot for your great work inbetween! And looking forward to 2.12.2 :slight_smile:

Hi @romio82,

Here is the latest build of VisualARQ 2.12.2, which includes the fix for the layer-deletion bug:

Take into account that if a layer is assigned to a style or style sub-component, you won’t be able to delete it, but a message will be shown on the command line.



1 Like

Wow, that’s a quick reaction! :ok_hand:
Thank you very much!

Hello! Had the same problem:

So it was in fact VA related! Will update…

Edit: fixed in 2.12.2!

Probably it’s just me doing something wrong but I get an “Error loading - VisualARQ.rhp” after installing the update you kindly provided so fast. Is it just me or can anyone else reproduce this?
Thank you!

Can you please in the Rhino Options > Plugins that both Tibidabo and VisualARQ are enabled?


Tibidabo is enabled, VisualARQ doesn’t show up in the plugins…
I’m currently trying on a second machine, maybe I’ve more luck there.
I’ll let you know in a minute.

OK, the Problem seems to be on my side, on the second machine the installation went fine and layer deletion works as expected.
Thank you very much @enric for this lightspeed fix!

Try to drag the VisualARQ.rhp into Rhino. You’ll find it inside the “PlugIns/Tibidabo” on your Rhino 7 installation folder.


Perfect, second solution within one thread.
Thank you very much!