Snapping despite all osnaps off

I have project turned on and was tracing a rectangle shape in a photo yet cursor snap was taking to lines in my project.
How can I trace something and have the trace go to cplane and avoid distracting lines pulling at the draw ?


The Project button on the Osnap control projects any object snap to the current construction plane. For example, in the illustration, the curve projects to the construction plane from snapped locations on an object.

project object snaps

I need to clarify incase I have misled. title said snapping despite osnaps off.

I had all osnaps turned off, by clicking on the osnap button (between planar and smarttrack) yet the tool kept snapping to things. I needed to draw over a photo and have the draw go to Cplane but not be tugged aside to a nearest line or whatever.
What should I be doing to stop anything snapping and have the draw go to Cplane.

With osnaps off the project selectable square click to depress is black so is that projecting to cplane or not ?
secondly how do I stop snaps still happening when osnap is off ?



If Osnaps are off, then the only way that I know of to still snap to objects is to hold down the ALT key. Maybe your ALT key is stuck, or you are holding it down when drawing?