Snapping issue


(Sina Khoshbayan) #1

When I am trying to work on a surface (draw a line for example) my mouse keeps snapping to the lines and points in the background. how can I prevent this from happening?

Please help. Thanks.


#2

Hi.

  1. Try to “raise” the snap window at the arrow to view all the options. 2) Deactivate the “ortho” menu in the upper menu. 3) hold down the alt key and try drawing the line to see if the snap is still active. 4) Close Rhino, restart the machine and try again.
    Sometimes it happens to have to “insist” with the alt key.
    Edit: reading the reply from @maxz , I have a feeling that I have misunderstood the question. I believed that the snap grid was active permanently…
    152696d6cfe8c06f19badb6add7bf2a8ada12228_1_690x431

#3

Activate the “On Surface”-Osnap. Alternatively, orient the CPlane (=construction plane) to the surface in question.


(Sina Khoshbayan) #4

I thank both of you for the answers. But unfortunately, it does not solve the problem. The on surface snap or setting c-plane helps a lot but still when I draw the line it keeps snapping to all the lines which are behind that surface. Is this normal? cause I have seen my partners working in rhino and it doesn’t happen on their computers…


#5

That is normal. It will happen a lot less when you switch off the persistent “Near”-Osnap, and only use that as a one shot when you need it.