Snapping drama

there must be a way to sketch smarter. I want to snap to an object but not leave the c plane I am on with the sketch. when I snap though to an point on another object it jumps off the cplane and the line suddenly goes not where i want it. any way to restrict a sketch to a plane but still snap to keep things lined up? Thanks

Try checking the “project” checkbox in the Osnap toolbar. All osnaps are projected to the active CPlane.

HTH, --Mitch

helve i owe you many a beer! thanks for all your advice!!