V-Ray beta backgrounds


#1

I don’t understand Background in the new beta. No matter what I do - I get black. I choose Color instead of Sky, I get black. I turn off that channel and only use the color slot next to Background - I get black.

I think I’ve tried every combination of turning one slot off and the other on and vice versa and both on and both off, and I still get black.

Thanks for any advice you’ve got.


(Andrea Montis) #2

you can use the background option in the v-ray frame buffer.


#3

Thanks for the reply but I still get a black background.


#4

You mean if you save it? At your screenshot the frame buffer background is blue … .


#5

Yes. The image to the left with the black background is the saved version from the frame buffer.


(Andrea Montis) #6

save as jpg, png has the alpha baked.


#7

It was saved as jpg. And I don’t understand why the Background controls in the Asset Editor don’t seem to do anything.


#8

At VfR2 there was the same behavoir. You need to disable the alpha output channel. But at the VfR3 this option is not available yet. Reported, but not confirmed as bug, could be a feature.

At VfR2 is use the alpha output always. But if I need the background, than the image browser XnView allow me to easy switch on/off the transparency of PNG. So, I was able to see the background. Maybe it works for VfR3 beta so too.