Silent Install Rhino 7.4.21078.01001

Hi,
I seem to have an issue with installing Rhino 7.4.21078.01001 silently, on install I am passing the parameter LICENSE_METHOD=ZOO and ZOO_SERVER=FQDN and others but once the install has completed and the user launches Rhino 7 the license method has to be chosen manually, Rhino 7.2 worked fine passing these parameters, any suggestions?
Automating installation of Rhino 7 for Windows [McNeel Wiki]

Hi! Did you find a solution to this? I’m having the same problem on Rhino 7.4 and all updates after it.

ZOO_SERVER=FQDN would not be valid.
We have a Zoo server in the office. It’s Fully Qualified Domain Name is “zoo.mcneel.com

I saw some message traffic on this several months ago and understood it was figured out.
If you’re still having problems with this using a current installer, please report back the command line options you’re running.
Thanks

Hi John,
I am not sure why ZOO_SERVER=FQDN would not be valid, in the McNeel Wiki for automating installation of Rhino 7 under the parameters description for this one it states “IP or FQDN of Zoo server to query” if I use “ZOO_SERVER=FQDN” that should work then, anyway I have tried the IP address of the server and that also did not work, below is my command line:
“%~dp0rhino_en-us_7.6.21127.19001.exe” -package -quiet -norestart LICENSE_METHOD=ZOO ZOO_SERVER=FQDN(CN.DC.DC.DC) COMPANY_NAME=“Company Name” ENABLE_AUTOMATIC_UPDATES=0
The install is run as the SYSTEM account.
Automating installation of Rhino 7 for Windows [McNeel Wiki]
Thanks

“FQDN” is a placeholder for the “Fully Qualified Domain Name” of your host Server. I’d recommend using the IP address instead.
DNS (Domain Name Service) resolves the FQDN to the server’s TCP/IP address.

Hi John,
Yeah I know what a FQDN is, I have sanitized the script as I do not want to post that info on a public forum, I have tried both the FQDN of the server and the servers IP address…

Sorry, I have no way to assess your IT skills.
I’m confused as to why this wouldn’t work.

Maybe when @brian can come up for air he’ll have ideas.

1 Like

Hi John,
Thanks for that, sorry I tried to add (CN.DC.DC.DC) to show you the format of the FQDN I should have made it more clear, thats my fault.
It seems to work if I take away every other parameter apart from license_method and zoo_server but I would need to do some more testing on that.
Thanks

@miika.rantanen this is a bug in 7.4 and earlier that is fixed in 7.5

Unfortunately, if you have 7.4 or older deployed, you need to uninstall 7.4 first, then install 7.5. Future deployments of 7.6 and newer will work as you expect.

@brian Thanks for that, if we have 7.4 installed then try and install 7.6 without uninstalling 7.4 first the parameters will not work correctly on the 7.5 or newer installer?
Below is how I am thinking of uninstalling Rhino 7.4, is this correct?
“%~dp0rhino_en-us_7.4.21078.01001.exe” -uninstall -quiet -norestart

TIMEOUT /T 05

MsiExec.exe /X {F41125BA-3559-477B-9005-A8AC8F8DF795} /qn

You should be able to just uninstall the exe; it will also do the uninstall of the MSI.

That’s correct: the bug is actually in the uninstall of 7.4 and older. Because of the way the upgrade install works, 7.4 uninstalls after 7.5 and newer installs. And that uninstall breaks the license file.