Sidebar spacing issue in the Rhino for Mac WIP


(Brian James) #1

Continuing the discussion from Rhino 5.3 WIP (5D129w) Can not select the command icons (El Capitan):

@jeff_hammond I’m not seeing this here in 5D132w with Osnaps hidden in the sidebar. Can you let me know if you still have this issue in that build?


#2

hey Brian.

yep, still the same behavior for me in the latest build.


that video shows an example of what @fuse was reporting in the thread… the issue that directly affects me, and i assume is related, is i generally have my left sidebar hidden (cmmd-0) …(i don’t use icons unless they’re in my popup menu).

when i launch rhino or when i open a new file, the left sidebar is always there regardless of me having it closed in the previous files…

in the official release, this behavior doesn’t happen… only in the last couple WIP versions.

thanks


#3

Hi Brian, I’m still getting the same behaviour on opening. Clicking on any other tab brings everything back to normal.

Here are my preferences - sorry in french - but you should be able to work out what I have as preferences.


(Brian James) #4

Thanks, I see this now too. Filed as https://mcneel.myjetbrains.com/youtrack/issue/MR-2963


#5

as far as i can gather, the issues in this thread have been fixed in WIP 5D143w.

:thumbsup:


#6

Unfortunately nothing has changed here. Also still experiencing laggy behaviour with beachballing while working. It’s as if something - memory? - gets fuller and fuller and everything slows down.

Edit: I actually managed to freeze it. Had to do a force quit.

2nd edit: Is this the culprit?


#7

Hi Brian, just downloaded the latest WIP, nothing’s changed… (sidebar, laggy behaviour, beachballing then freezing) Is it my computer or?..


(Brian James) #8

Are you still seeing the bug of the icons not being shown entirely or the sidebar not staying hidden…
https://mcneel.myjetbrains.com/youtrack/issue/MR-2963
Or are you still seeing the inactive icons issue…
https://mcneel.myjetbrains.com/youtrack/issue/MR-2933
or both?


#9

Icon bug - this…

I can live with that because as soon as I hit any tab it goes back to normal.

What is very frustrating is that the WIP versions since around Nov. 2016 lock up after about 10 mins use (see my message above - Nov. 16th). The behaviour becomes very laggy finally beachballing. I have to force quit. These are very light files around 5 Mo.


(Brian James) #12

I’m not sure why you aren’t seeing the icon fix. Can you try running the ExportPreferences command and save those old ones to the desktop (or somewhere). Then try the ResetPreferences command and see if the behavior is any different.

Regarding the lag you are experiencing with the WIP after 10 minutes of use, I’m wondering if you can post one of these small files, or send it to tech. Detail the commands you use and what you are doing for the 10 minutes if you can too. I think this would be best as a separate post if you want to share the file on the forum. Please make a separate post so we can focus on just the lag issue in it’s own conversation.


#13

I exported my preferences and then reset, I’m still getting the icons I saw in my last mail…

Could you give me techs’ email, thanks


(Brian James) #14

tech@mcneel.com

@dan I’m not sure what to suggest next, do you think this might have something to do with running a non-English language pack?


(Marlin Prowell) #15

Please post a description of your hardware and Rhino version as described here: Reporting Problems with Mac Rhino. Thanks.


#16

Hi marlin,

Software information

Software versions
Rhinoceros version: 5.4 WIP (5E7w)
IronPython version: 5.1.2015.131
WIP expiration: 3 mars 2017
Language: fr
macOS version: Version 10.11.6 (assemblage 15G31)

Plug-ins
None

Third party kernel extensions
None

Hardware information

Computer hardware
Hardware model: iMac13,2
Processor: Intel Core i7-3770 CPU @ 3.40GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GTX 680MX 2048 MB
Memory: 2048 MB
Screen size: 2560 x 1440
Displays: iMac (109dpi 1x)

USB devices
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Bluetooth USB Host Controller
Logitech: USB Receiver
Apple Inc.: Apple Keyboard
AKS: HASP HL 3.25
Apple Inc.: MacBook Air SuperDrive

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.10.13 310.42.25f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 8x
Mip map filtering: Aucun
Anisotropic filtering: Élevé


(Marlin Prowell) #17

This should be fixed in the 5E12w WIP that is currently available.


#18

Unfortunately not here… this is what I get with 5E12w


(Marlin Prowell) #19

I explicitly tested this and I cannot duplicate this. Please write very detailed directions about how to duplicate this, starting with ‘Start Rhino’. Also include your preferences file created by running the ExportPreferences command.


#20

Well just installed the new update and this is what it looks like - just opening Rhino, nothing special… no buttons, tabs or mouse clicking… ok, Rhino is assigned to a desktop

preferences:-

abprefs.plist.zip (23 KB)

and here is a file, it’ll do it with any file I open…

GG.3dm (3.8 MB)


(Marlin Prowell) #21

This thread is about sidebar spacing, but I see now that is not the issue you are describing, but instead something entirely different.

You changed your sidebar palette (“Palette de la barre latérale :”) to be Vue, and sometime later you enabled Show ribbon bar (“Afficher le ruban”). This has the side effect of disabling the sidebar choice, since selecting different tabs in the ribbon bar will change the sidebar contents.

When Rhino starts, it is setting the sidebar to Vue, the tool palette you have chosen. Selecting different ribbon bar tabs then change the sidebar contents.

I’ve changed Rhino to ignore the sidebar palette choice entirely when the ribbon bar is visible, and this fix will be in the next WIP release.

To fix this now, uncheck Show ribbon bar, change your sidebar choice to Main, then recheck Show ribbon bar.


#22

Brilliant Marlin, thank you very much! Everything is back to normal. Never in a month of Sundays would I have found that.