Minor sidebar niggle with SWM


#1

Hi Marlin,

This may have been reported already, the left sidebar, which I have set to the minimum of two wide with just Main, goes back to 4 wide when I quit and restart Rhino…

And thanks for the SWM interface, I will be starting teaching my class this Friday, and although some might take this as an insult, it now sufficiently resembles Rhino for Windows (or can be set up that way) that it will make things a lot more understandable for the more than 50% Mac users…

–Mitch


#2

what version are you using? i’ve seen what you’re talking about in a couple of the earlier single window releases (as well as toolbar width changing sizes when going from full screen back to normal screen)… but it’s been ok for me the last couple of versions.


#3

Just downloaded the latest version - 2014-02-18…
–Mitch


(Marlin Prowell) #4

Mitch, I’m glad the UI changes are workable enough for you.

The sidebar widths on each window are independent of any of the other windows. As far as saving the sidebar widths, Rhino currently saves the widths of the last window closed, not the last window whose widths were changed. The latter seems more natural, and I’ll see if I can get that to work.

In the meantime, start Rhino, adjust to taste the window that opens, close the window, quit Rhino. That should retain the sidebar widths you want.


#5

Hi Marlin,

That’s what I tried, but it isn’t “sticking”…

–Mitch


(Marlin Prowell) #6

I cannot duplicate your problem.

I’m NOT running 10.7.

In Rhinoceros > Preferences > Themes,
Custom
Use command options dialog
Include Osnaps panel is OFF
Sidebar palette: Main


#7

OK, now I can’t either, it seems to have decided to behave… I tried this about a half dozen times last night, and it always reverted, now it stays put… And I didn’t even restart the computer between, was just on standby… go figure.

Anyway, if it starts happening again, I’ll let you know.

BTW, I am running the latest Mavericks and MacRhino…

Cheers, --Mitch