ShowSelected takes a long time

Hi. I am again here with same experience but in other command. Rhino is super very slow. About 15 to 20 times slower than rhino 5.
Here, using command to hide (ctrl+h is ok for both, V7 and V5 (V6 works same as V7 - I have already compleained years ago) But using command unhide (ctrl+shift+h) is incredibly slow in V7 (V6)

I have installed fr this test both, V5 and V6 to compared it with V7. In video, you can see that in V5 it takes no more than a sec to unhide an object. In V7, it takes neraly 15 sec to show hidden objects and than about 20 sec to bring it to the scene back after click. Since it is on the same computer, exactly same file, there must be a bug in V7.

Is it specific to this file? or is it consistent everywhere?

It happens with every file. And the same thing is with LOCK/UNLOCK objects and similar actions.

Just to avoid already discussed solutions I found somewhere but not working:

  • Toggle gumball
  • close properties (material, layer, lights, ground plane etc. tab)
  • turn of cycles plugin
  • setting Quadro according to this manual: NVIDIA Quadro Video Issues [McNeel Wiki]
  • turning on/off antialiassing/tesselation: Options/View/OpenGL
  • resetting display modes
  • upgrading driver (I have to follow certified drivers for Solidworks which is even more sensitive to the right one)

Since I have this issue (is it only me or few of us? why my godness) from V6 (pen/technical views) and hide unhide (etc above) It must be somehow related to Rhino itself (V5 works just fine on this machine.)

here is system info:
Rhino 7 SR29 2023-4-17 (Rhino 7, 7.29.23107.03001, Git hash:master @ 5f05ef3a2eea3d910c4c2fb79ccc75b413d33ca7)
License type: Commercial, build 2023-04-17
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 6-1-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1
Primary OpenGL: NVIDIA Quadro P1000 (NVidia) Memory: 4GB, Driver date: 3-9-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 528.79
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-9-2023
Driver Version: 31.0.15.2879
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi -

So, if you start a new file from a factory-default template, create a box, hide it, and then run ShowSelected, this will take about 35 seconds to complete?
-wim

@dyzajn I do not see that behavior here, unless the problem also shows on a fresh scene with one box, is it possible that you send us a model that shows this behavior? If confidential, you can use Rhino - Upload to Support
please link back to this thread

I have just tested with the box. That works.
I exprted the whole model I can see in my scene a imported to the blank scene and it works!

So. What could cause the problem?

Correction. Its not working. After exporting whole scene to a new one and importing to a blank scene, it does the same lag
The file size also increases unexpectedly

I have sent the file to the tech support. Thank you

I will look into it, thanks
@dyzajn I am seeing the slowness here, I’ll start digging
…
It looks the 35000+ curves in that file are choking it. In V8 all goes fast though
RH-75196 ShowSelected is very slow in this file

1 Like

@dyzajn it appears that Displacement plugin is somehow involved. If you don’t need it, you can disable it for now in Plugins and restart Rhino. It’s not sure if this will be fixed for Rhino 7.

YES! Thank you so much! It works both isolate, show hidden!