Hide/Show Really, Really Slow

Hi All,

Got a ~150MB file running in V7. Select part of the drawing and show or hide - taking 2m10s. Same file in V6 completes same operaion in around 2s.

Selection set = 139 block instances, 701 hatches, 5 points, 201891 curves, 62 surfaces, 365 texts, 1 linear dimension, 4 radius dimensions, 96 Leaders added to selection.

Also taking a really long time for editing to become available after selecting an entity like a dimension or text.

Any ideas?

Can you run SystemInfo in Rhino and copy/paste the results here?

Here are the results

Rhino 7 SR5 2021-4-10 (Rhino 7, 7.5.21100.03001, Git hash:master @ 2cd158094b595f6400479d7cbe511454b6149527)
License type: Commercial, build 2021-04-10
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro RTX 4000 (NVidia) Memory: 8GB, Driver date: 2-9-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.55
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1
- Secondary monitor attached to adapter port #2

Secondary graphics devices.
Intel(R) UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 10-28-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-9-2021
Driver Version: 27.21.14.6155
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\SimLab\Plugins\SimLab 3D PDF From Rhino 6\plugins\SimLabPDFExporter.rhp “SimLab PDF Exporter”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\rupe\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”

Ref comparison on Rhino 6. Was on the same machine, at the same time (no other software open) and the entire file components copied and pasted into new files opened in both v6 & v7. Also tested after system reboot - same result each time.

Also tested on another similar machine in the office running another license of v7 - same.

There have been periodic reports of this slowness and some fixes have been applied, but there still seem to be people who are experiencing this.

I guess a couple of things to try to narrow down the cause -

Temporarily disable SimLab and SectionTools plug-ins
Try the selection/show/hide with the Properties panel closed
Try with some individual object types to see if it is one or the other that might be causing the slowdown

Thank you for the suggestions. Results as follows:

  1. Simlab & Sectiontools off - no change

  2. As per 1 with layer tab, rather then properties tab, active - no change

  3. As per 1 with properties panel closed - no change

  4. Tried show/hide with:
    a) No points selected- no change
    b) No curves - instant(ish)
    c) No blocks - no change (maybe marginal but >2min)
    d) No hatches - no change
    d) Just curves selected - 1min

If hide not completed within 20 seconds then i hard stop it and re-open file…

So for now am running out of patience, and opting to work in v6 where same file runs quickly.

Anyone from McNeel want to look at the file and try figure it out?

So it appears the 200K curves are the principal cause?

I agree with the (ish), selection in V7 is still a tick laggier than V6 even when there isn’t a massive delay as you’re experiencing.

I’m sure someone will - @wim?

Hi -

I have a file here with 246 129 curves where hiding / showing parts of them takes around 5 seconds and it behaves the same way on Rhino 6 here. So, yes, please upload a file on Rhino - Upload - you can use wim@mcneel.com in the recipient field and please paste the url to this Discourse thread in the comments field.

Do you have 3 screens connected to you machine? Does it make any difference if there’s only one screen?
-wim

Thx Wim, Have uploaded the file. Yes, 3 x screens. Unplugging 2 made no difference.

Hello - there have been fixes in this area - you can try the 7.6 release candidate by changing the ‘Update frequency’ in Options > Updates and Statistics page to ‘Service release candidate’

Further fixes are in the 7.7 build which should become available next week as a release candidate.

-Pascal

Thx,

SR7.6 show/hide working much quicker now. On a par or better than v6. Always appreciate the McNeel progress and Rhino updates.

Still experiencing significant lag between selecting an object and edit becoming available. I.e. text or dimension annotations and control points, or making fillet between curves etc. This works fin and quickly on small files, but very tedious on large files. Is there work in progress on this too?

Hello - yes, the 7.7 release should make that better too.

-Pascal

Cool, will leave my v7 update frequency on SR. Thx all.