Rhino extremely slow when selecting objects in viewport (bug?)

Hi!

I’m running against an issue with Rhino. When I am selecting objects from my viewport there is a weird delay of a couple of a couple of seconds from the moment I click until it selected and highlighted in yellow. This happens maybe 10 to 50% of all object clicks. No idea why. When I select all object (control +A) the selection is instant. Same goes for selecting object from the layer menu.

I don’t see a difference between light or heavy scenes.
I am running the latest graphics drivers and my PC specs should be able to handle a scene with ease (3950X 64GB and 2070 graphics)

I have reinstalled Rhino and tried to reset everything to default. No luck. I am running two plugins: For Lumion and for Keyshot.

Any idea how to solve this?

What version of Rhino? If V6 or V7 run the Rhino command SysInfo and post the results here.

How many objects in the model? How big is the file?

How far from the world origin are the objects?

Hi @jonas.samson
Here’s a link to someone with the same problem: Rhino 7 slow and not responding - #14 by pascal
First thing to try is to disable the Lumion and the Keyshot plugin, and see if that helps.
HTH, Jakob

Hi David,

This issue is regardless of how big the file is or how many objects there are in the scene or placement from the world origin.

I’m using the latest build of Rhino 7
Sysinfo:
Windows 10.0.19042 SR0.0 or greater (Physical RAM: 64Gb)

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2070 (NVidia) Memory: 8GB, Driver date: 2-23-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.72
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-23-2021
Driver Version: 27.21.14.6172
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\KeyShot10RhinoPlugin (ccedd9da-83b9-429a-aec5-8ec90b85fe67)\1.0.0.0\KeyShot10RhinoPlugin\Rhino 5.0\KeyShot10RhinoPlugin.rhp “KeyShot10RhinoPlugin” 1.0.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi Jonas - this is very much a shot in the dark, but can you try, in the current display mode for the view that is slow, editing the mode to add a small amount of transparency to the grid:

Does that make any differnce?

-Pascal

Hi Jacob,

Tried with disabling both the plugins. No luck.
Didn’t find any solution in the link you send either unfortunately

Hi Pascal,

thanks for the tip
tried that… no luck yet

Hi Jonas - is the Properties panel open? Does it matter if you close it?

-Pascal

1 Like

WOW! that was it. I closed it smooth and should be.
But why? And now what…leave Properties panel closed?

You are total life safer! thanks so much

I had the same problem I noticed now with selecting loop rings. Very slow…
Also solved when closing the Properties panel

Hi Jonas - thanks for testing - this is not a solution - but at least we know where to look.
@jonas.samson - another thing to test is to have Gumball off while selecting (and Properties open)

-Pascal

Hi Pascal,

More specifically, it was not the proporties tab but box edit tab causing this.

Best,
Jonas