Short edge problem

I have a problem inserting a closed polysurface created in rhino in Revit. I try exporting as a dwg and importing it in a generic model family but when I explode it the object disappeared.
I also tried rhino inside where I see an error of short edges. But how I will find these short edges. It looks fine to me in rhino environment. No naked edges, no manifold edges.
Is there a way inside rhino to find these short edges?
short_edges.3dm (1.1 MB)

Try this for a better display of the issues.

This post may help you as well.

1 Like

99% is human mistake while modeling.
I attached the corrected file which has no problem importing in revit.
I am thinking that even if I don’t need to import a model in Revit, modeling from Revit inside environment, is easier to find when you make a modeling mistake.
In my case, I found one mistake where two endpoints that should have the exact coords, had a distance of 0.00043 m. I know that continue modeling from this point is going to produce more problematic areas.
Is there any plugin in grasshoper, able to find sort edges without modeling from rhino inside?

What i still dont understand is that if i explode the fist model, which i am unable to import in revit, set the tollerance to 0.000001 m, and then join again the result is a closed surf without naked or manifold edges. How its possible? The result should be an open polysurf in this tollerance. Else revit should have no problem importing it.
The model i think is closed polysurf only in 0.001 tolerance.

corrected_model.3dm (1006.3 KB)

You can do a tool like this yourself with Grasshopper. (21.3 KB)


Thank you very much.
That’s what I was looking for.


Thank you for sharing this tool. I ran into the same error when sending some geometry to Revit.
However, when I tried using your tool, I got strange results. You can see it reports 4 edges in the panel, but has arrows everywhere in the viewport. If you look at the bottom of my Rhino you will see that I have selected all the geometry, and it is only the polysurfaces you see highlighted. So why are the arrows pointing in empty space?

Is there another way for me to find exactly where those 4 problematic short edges are in the model?

Thank you for your help.



Can you post the problematic geometry?

Yes, thank you. It is geometry provided by a colleague so I am not as familiar with how it was constructed.
Problem Geometry Short Edges.3dm (1.4 MB)

I’m not seeing the extra error issue. Perhaps download Kike’s definition and try again.

Something like this would work as well…

Reloaded Kike’s definition and it is working, as is the one you offered. Thanks