New Component - issue with untrimmed surfaces

I’m getting an error with the new component widget. It works on breps but has an issue with untrimmed surfaces. I’m pretty sure this was working at some point, but now has stopped potentially from one of the more recent updates. I’m on the daily release schedule.

Hi Ben, Everything looks ok here. Can you provide your about details and any additional info that can help troubleshoot? thanks.

I took a screen shot of the about section.

I tried it again with a simple setup, same issue.

I also have Rhino 7 installed, so that might be an issue. I’m currently using the Rhino 8 beta. I’m keeping everything updated on the Rhino side and the Rhino inside side so it should be the latest releases.

Thanks for the details, I was able to replicate.

I’m seeing this issue as well:

It seems like the import engine still needs some work. This came from Revit into rhino and then I’m trying to pass it to Rhino again, so I presume it should be in good shape.

I’m also on the daily build, so maybe I’m picking up every bug as it comes out:)

Revit can create out of tolerance conditions. Converting Revit Geometry into Rhino and back to Revit does not guarantee that it will be within Revit tolerances.

I tried rebuilding the edges and checked the tolerances in rhino based on one of Scott Davidson’s articles. There are no manifold or naked edges. I used the sel bad geometry command and the check command. Everything looks good in rhino. Is this an issue of small geometry? I had that issue with lines. How do I reliably transfer geometry into Revit? I’m a little frustrated, it seems like a crap shoot right now . . .

Just trying to figure out some guidelines . . .

Here’s an example of finding edges that are too small.

Edges is a good place to start. There lack of documentation of the Revit geometry kernel does leave some guess work.

What are the recommended tolerances I should be using?

Seems to work a lot more reliably with simple geometry without a lot of detail, even if that detailed geometry came from Revit! Seems like Revit’s geometry kernel is not easy to work with . . . Any improvement to the way geometry is imported and exported to Revit would be great. Right now its a bit fussy . . .

Thanks for the short edge tool will take a look a bit later. For now I’m keeping it simple to avoid all this trouble shooting.

I posted another issue with the geometry kernel / import into Revit. BRepBuilder cannot assign edge geom & Method not found error - Rhino.Inside / Revit - McNeel Forum

I’m not sure if this should all go into one topic or if I should report a bug? I’m using the latest build. I think there are some larger issues with the latest build since its having trouble with simple geo, like a sphere, and other simple geometry which passes all the tests, short edge test, no manifold or naked edges etc.

The Method not found error seems to indicate that something was broken by the team in the latest release? Something renamed, a method deleted? I’m getting that same set color method error which might be triggering other issues like cannot assign edge.

Can you have the team take a look? If this is indeed an issue in breaks any workflow involving bring Rhino geo into Revit in the latest daily build which is of course a core function. This does not appear to be a user geometry issue unless I’m missing something.

Hi Benjamin, I was able to replicate and filed a bug report. How soon it gets addressed is governed by the Dev priorities & how complex it is. This one seems fairly innocuous & should be resolved soon.