Shift+ctrl box selection SubD

Just started using SubD in rhino and for some reason I cant select the vertices with ctrl+shift select to be able to edit the points. I can if i use the show edit points.

Anyone come across this before? Dont all shout at once :frowning:

can you do a screen recording showing this behavior? It’s working well here, and I want to make sure I’m understanding your issue correctly.

1 Like


I can select face ok, just not the vertices . I have to enable control points so i can edit the SubD. IM using rhino 7, (7.2.21021.7001, 21/01/2021)

in the selection filters, do you have sub objects checked?

Will have a look on the morning. Pretty sure it’s not checked. I was using the filters for the control points though. Will get back to you.


so i enabled sub objects without surfaces/faces, curves/edges/ points/vertices. and cant select. Then cleared sub objects, and dosnt work. Disable allows selection of faces single points. but i still have to enable control points to be able to box select

OK found a solution, i dont know if its a problem to

be sorted by the tech team or it just my inexperience.
see the video. I can select the vertices by just using shift, ctrl+shift dosnt work. Checked the option in mouse settings. seems to work. I dont know if the sub objects filter is supposed to activate selecting in options? anyway it works with the shift key and allow of sub-objects in the options.

will you post your systeminfo from rhino? I’m curious about your graphics card sitch-

That was my thought as well. I upgraded the driver on the card this morning against Dell’s confirmed certified drivers . But I didn’t check the box in options prior to the driver change. Will send the info. Does my system info need to be private?

no, simply run the systeminfo command in rhino and copy/paste the report.

Other than your machine name which you can redact out if you want, there is no personal info in the report.

If you see anything, can you let me know, many thanks.

Rhino 7 SR2 2021-1-21 (Rhino 7, 7.2.21021.07001, Git hash:master @ 96ff97351fbdf5d2acdeaf781aea1577f2ff60f7)
License type: Commercial, build 2021-01-21
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 4GB, Driver date: 1-22-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.40
> Integrated acclerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel® UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 5-19-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-22-2021
Driver Version: 27.21.14.6140
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\XNurbs (80be33b0-13b2-4ac4-9c77-03829214f9e9)\5.0.1.0\XNurbsRhino.rhp “XNurbs”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

All looks ok,

peek at this thread, your machine reports non hybrid, but it’s worth following the steps-

https://discourse.mcneel.com/t/soooo-you-bought-a-laptop-with-hybrid-graphics-and-rhino-doesnt-run-right-read-this/109982/2

also always a good idea to set your nvidia 3d settings to this -

Many thanks.

Still dosnt work with ctrl+shift select , but does work with shift select only with the sub-objects on then use the filters to select points and disable faces inside the subD geometry.

that’s odd… any custom stuff? mouse, keyboard, gamer add on’s etc?

It may be worth trying a repair on your rhino install- (or help>check for updates)

Good point. I have a logi Bluetooth keyboard and mouse logitech mx master 3. Moghtvtry and save settings and do a install again. Do I just download from rihno the latest update.

Is thier a clean uninstall process. Might look for one. Hopefully the reinstall will sort it .

Thanks very much

installing the updates is good enough, I’d look at any custom bits in your mouse/ keyboard chain…

Hi,
I have the same issue.
I tried installing Logi software, but Ctrl+Shift is not selecting SubD.

Did you find any solution?

I have the latest SR17

Thank you

René Medel

Not really, learned blender instead

Haha… well, I will stick to Rhino.
But Crtl+Shift is driving me crazy.

Thanks anyway

@theoutside Hi Kyle,
Since you are the SubD master… Have you heard about how to set the Ctrl+Shift combo in this Logi Mx keyboard?
Thank you