How do I select a Sub D face?

Day one for Rhino 7.0.

Watched Brian’s introductory video on Sub D, and I understand from it that to select a single face on the surface of a Sub D box (for example), I should use Shift-Ctrl and then right click on the face I am interested in. In the presentation the gumball is ON, so I am using the gumball.

Nothing happens.

The face does not light up yellow to indicate it has been selected.

I can follow the same procedure and select successfully an Edge, but not a face. Haven’t tried to select a Vertex yet. IIRC tSplines had hotkeys to pop from Faces to Vertices to Edges. Maybe there is some similar facility in Rhino 7.0. I can see three filters, but it not clear if they are intended to allow or to exclude faces.

I gather the Shift-Control elicits a command, maybe something like Select Sub D (face, edge, vertex), but I am not finding it.

There exists an icon for selecting a single Face, but it has no effect.

Probably something so utterly simple that the answer has been assumed to be obvious, but here I am. Can’t light up a face.

Thank you for your insights.
Michael
subdee box.3dm (38.4 KB)

You are correct about ctrl+shift clicking.
But you should left click.

2 Likes

Hello Lars, thank you for your suggestion.

I tried Shift-Ctrl-LeftClick, but the Face did not light up. This technique will select any Edge successfully, but not (in this file) a Face.

Best, Michael

I can confirm that Shift+Ctrl+LeftClick does work in your file.
Maybe you have selected the Selection Filter for Surfaces/Faces, in that case you only need to LeftClick.

Thank you for your help. Since the problem is not in the file, it must be in the settings on my Rhino 7.0. I may reset it to the default, initial settings and see if the problem disappears.

By clicking on the Selection Filter for Faces I find I can select a Face with a Left Click. So as a practical solution, I will work with this method until the logic becomes clearer. Thanks again. Michael

Kyle Houchens has solved this by email, as follows:
“…you will need to be in one of the shaded modes to [select a face], unless you filter for faces and then drag or directly select the faces. (no shift +ctrl click”

In other words, I was unable to select a face using hotkeys because I was using a Wireframe. When I switched to Shaded or Ghosted, the faces appeared and the hotkey selection method for faces suddenly worked.

Net. If you are using Ctrl-Shift-LeftClick you will need a surfaced structure in order to select a face.

If instead you use the Face Filter, you can work with a wireframe structure. Select an edge, and the system will offer you a choice between the two faces that share that edge. Thanks Kyle!

1 Like

Are you in wire frame view mode?
Only shaded modes will highlight faces - in my limited experience