Ctrl+shift select not working or very insensitive

having a difficult time selecting subobjects something i don’t have an issue with in v6, my filter is set properly. thanks.

1 Like

I thought I was going insane having the same issue, like my fingers suddenly became more clumsy. Would never expect it could be software-related.

oh good, glad i’m not the only one, not good but you know what i mean.

have you tried the new wip? seems like it’s better, what are you seeing?

I only started using it, had to drop for a while due to the printing problems.

I have the same problem. Just installed the latest WIP.

Control-shift click is completely nonfunctional. Control-shift-frame selection works normally.

Also, the SubD selection filter buttons don’t work. They all get “unknown command” in the command line.

Tried restarting and tried _ToolbarReset, neither fixed anything.

We need a patch, ASAP or we’re gonna have to reinstall the previous version.

@brian, @BrianJ HALP! HALP!

subd sub object buttons don’t work here either, but are you sure you don’t have sub-object filter on? Then the Ctrl+Shift is not needed, and you can select subobjects the same way as normal selections (Shift = add. Ctrl = substract from selection). This is the same as in v6

I solved my problem by deleting Rhino and also from the registry editor …
Of course, Ctrl + shift select is still numb
HKEY_LOCAL_MACHINE\Software\McNeel\Rhinoceros\7.0
HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\7.0

def don’t have mine on

Didn’t have mine on either. Also got impatient, wiped the latest WIP and installed the last version I had in my downloads, from late January.

Aaaand control-shift click subobject selection is STILL broken, even though I reverted to an older WIP.

With the selection filter subobjects box checked, normal click subobject selection of edges and vertices works but only if I zoom in very close and even then sometimes it fails. Face selection by single click doesn’t work.

With the selection filter subobjects box unchecked, control-shift click subobject selection doesn’t work, but control-shift frame selection of subobjects does work. Deselection of faces by control-shift click works. Deselection of edges and vertices by control shift click is much, much more difficult than before if it works at all.

Very very weird.

Also: important information: I am using a high-res screen. Is this a proximity problem? Has proximity needed to hit a subobject been reduced to no radius? Am I only succeeding when I hit a single pixel? Is there a setting for this radius in options?

Anyway, what I’ve got here is a non-functional WIP, basically, and I can’t revert. :frowning:

Max, do you have this advanced setting disabled?


I’m actually not able to reproduce ctrl+shift select not working with it off though so it may not have an impact. I’m hunting for some way to make this happen to help fix it. I’m on a 4k monitor here too and don’t think this could be related to that. Check your display scaling in Windows though in any case as that can cause mouse click offsets I think.
@pascal This may be related to the select filter stuff you were digging into.

It wasn’t disabled. Disabling it made frame selection of subobjects top working, re-enabling brought me back to my original problem.

Also since reverting to a prior WIP didn’t fix my problem, I’m back up to date.

@BrianJ - so far everything seems to work as expected here in the latest BOTD.
-Pascal

Is there a reliable way for me to wipe out all traces of the WIP and reinstall?

Have you tried running the installer again and choosing Repair yet? FYI @brian in case you have any ideas of what this might be caused by as well.

I tried that. It didn’t work.

Then I tried something else. I had been importing my options from rhino 6. Every major WIP update seems to revert to default options.

So I went to my options, and tried restoring them to default. I restored defaults for my view options for Shaded view first. That fixed the problem. And when I manually changed those options back to what they had been before the restore, the subobject selection problem did not return.

I don’t know how things work under the hood but maybe because the WIP has more options than Rhino 6, something getting jumbled in the import?

One other minor bug I noticed earlier is that it seems like any option that only exists in 7 and which has been manually changed from the default in 7 will get restored to default if the user imports options from Rhino 6. For example: any changes to view options for SubD objects get wiped after an import. Makes sense, sorta: values getting replaces with nulls or something?

Anyway, that’s the bug I have. Not sure if it’s what other people have. And I’m not sure if it’s tied to a specific view option, but if I had to guess one, it’d be wire thickness, curve thickness, etc.

I’m on a highres screen so have some of those bumped up as high as 5 or 6. In rhino 6, subobjects selected are highlighted at the same thickness. In the WIP, an edge displayed at 5 pixels thick highlights with a one pixel thick overlay. I have no idea how any of this works under the hood, but there seem to be some mismatches here and maybe that’s causing some kind of conflict in the code?

TLDR: Using _OptionsImport in the WIP to open a file created with _OptionsExport in Rhino 6 broke subobject selection in the most recent WIP. It didn’t in previous versions. Restoring default options in the WIP fixes the bug. After restoring default options, manually returning options to where the import had put them did not recreate the bug.

This is strange. Your options are stored in a settings file that is specific to Rhino 7, and is not touched by the installer. It lives here (paste this location into Windows Explorer)
%appdata%\mcneel\rhinoceros\7.0\settings

Can you please attach your options file (or DM me with them if you don’t want them public) so that I can test this? There are so many settings that it’s going to be hard for me to try to reproduce this just from your description.

Is there anything that could be in my options that would be a privacy problem or security problem?
Or would the rationale for not sharing publicly just be if I felt super secretive about my methods (I’m not).

DMing now. Will add to post if you confirm there’s no reason not to. I quite like my dark mode and am happy to share.

Hey, @kleerkoat, @Piotr have you fixed this bug yet on your machines? If so, how?

I am afraid of messing with my settings that would stop me from working. I work on a tight deadlines and can’t afford it.
I became more aware of the issue and adjusted my work style (cursing more often too).
I have recently messed with some Windows display settings which seemed to be banal (font scaling issue on a second screen) and I can’t restore it to the original settings. Had my lesson learned.

@Max3 i installed the latest beta and it solved itself. i’m sorry man.

1 Like