Soooo, you bought a laptop with hybrid graphics and rhino doesn't run right. READ THIS

Hybrid graphics laptops are more and more common if you buy a consumer grade machine. (I recommend buying a mobile workstation for professional modeling but these hybrid machines are quite prevalent in the consumer market, especially for students.)

They tend to generate a TON of tech support here because of the way they are set up from the factory.

Hybrid systems are built with 2 graphics processors. A low power graphics chip (typically Intel HD or UHD) and a high power graphics card. However, they typically are set up to preserve battery life at the cost of performance by using the low power Intel as the primary graphics resource. This is typically BAD for Rhino, as the Intel has 1gb or less vram they tend to cause all manner of graphics issues, crashes and generally poor performance.

(If you are a student, I’ll translate… “Intel onboard graphics are Jank for Rhino Yo”)

If you are here, I’m assuming you ignored this post- If you are buying a new laptop READ THIS and bought one anyways and now you are stuck with it… what to do.

The good news is these machines CAN run Rhino well, you just have to change their default set up.

See this info from our display dev below- (edited for this post)

You can force the “High Performance” GPU at the windows level by creating an application profile from within the Display Settings dialog …

With Rhino CLOSED Right click on your desktop and choose display settings-

Scroll to the very bottom of that page, you should see an option for “Graphics settings” … click it

A new page appears.

Make sure “Classic app” is selected…then click “Browse” button and locate Rhino 6’s .exe file.
It should be located here-
C:\Program Files\Rhino 6\System

Once it’s located, Select it…and you’ll see an Options button appear…
Click Options and select “High Performance”

Close the dialog and start Rhino… theoretically and hopefully, the NVidia GPU will now be listed as the Primary OpenGL device and Rhino will use the High powered card at all times.

Make sure your Video Card drivers are up to date and you will have solved a huge piece of making Rhino run well on a hybrid machine.

You may want to (but shouldn’t need to) additionally check your Graphic card control panel and additionally set open gl and the power use to max performance, On NVidia it looks like this:

Happy Rhinoing!


Thanks! Did this however this keeps coming up “You are not current using a display attached to Nvidia GPU. Display settings are not available”

make sure you are connected correctly-

if you have a desktop and are connected to the onboard video port, you are not using you nvidia-

check this link-

if you are using a laptop with an external monitor, make sure your laptop monitor is set to be the main display, NOT the external.

still not working? call us at tech and let’s take a peek-
(206) 545-6877

1 Like

Tried everything you mentioned above and rhino 7 still won’t open. Are there any other solutions?

In Windows Device Manager > Display adapters, do you see one named ‘Citrix’?

Not exactly know what eventually was the solution. I first uninstalled citrix but it didn’t work. Then I tried reinstalling rhino and now it works. For now it is solved. Thanks!

Microsoft really screwed up the high-performance graphics settings. They likely will be bitcoin mining in the background. Waitforit.