ShapeDiver QR link for AR model fails on Android, works on iOS

Hi all!

As the title says, I have created a few different models on Grasshopper to be displayed in AR on mobile devices. When following the QR code (displayed on the computer screen), iOS works fine and quickly displays the AR model with no problems at all, whereas Android opens the link but immediately redirects to the main page: ShapeDiver. I tried copying the link and opening it on different browsers on Android with the same result. I also tried it on completely different Grasshopper models that I’d uploaded, and the problem was still the same: iOS works fine, Android redirects to main page. I also tried removing the part of the link after .html, to no success.

Any idea on what might be causing this?

Thanks!

We would need a link to the model that is causing the issue in order to replicate the issue. Since it is happening to several of your models, ideally you could create a simple example that you can share to help us investigate.

Sent you the link in PM :slight_smile:

We tested your model on several android devices and could not reproduce the issue, the model opens as expected in the AR viewer. Could you give more details about which android device you are using to open the AR viewer?

Hi Mathieu! Thanks for your time in troubleshooting the problem. After a long discussion with a friend we figured out what’s happening: I have Firefox as my default browser on Android. Copying the link from the QR code and pasting it in Chrome doesn’t work either, but making Chrome the default browser does! So I guess it might be related to Firefox not reading the intent filter correctly?

As for now, I’ll just switch the default browser to Chrome :slight_smile:

Hi again! Last week I asked a group to students to open the model based on its QR code and for the vast majority of them it didn’t work. I assume they all had different kinds of Androids. I’ve been asking all my friends to try too, and it mostly fails. Is there some possible workaround to perhaps just get the link as text or so?

Hi Pol,

Could you confirm if you’re just sharing the QR code or the actual link to the ShapeDiver model?

Hi Ezequiel! Sorry for the late answer.

I took a screenshot of the QR code and shared it. It worked fine on some phones, not at all on others.

Hi Pol,

thank you for your answer. Our QR codes are only valid for roughly 24 hours before they need to be regenerated (they expire), so sending a screenshot of the QR code alone is not a good practice. For optimal results, send the link to the ShapeDiver model on the platform or the page where it’s embedded via iframe. Could you try this workflow instead and let us know?

Finally, the Android ecosystem is unfortunately quite segmented. Some phone brands do perform well with our AR approach, while some others don’t. We’re trying as best as possible to cover as many phones as possible, but it’s just not feasible to guarantee that this will ever be as uniform as with iOS.

1 Like