ShapeDiver problem with displaying geometries in the viewer

Hi ShapeDiver team,
I have some geometries that are displaying perfectly fine in grasshopper, using the glTF2.0 display component, but when I upload the file in shapediver it only shows a part of it.
All the meshes are flatten before using the display component. I don’t see where the problem could be.
Could you help me with that?
Also, as it is not the first time it happens, do you have any tips to check the file and find where could be the problem ?

I am using Rhino7.
Hypersolar_SD_test.gh (1.3 MB)

Link to the shapediver viewer : ShapeDiver
Thank you, Ilona

The shared ShapeDiver system is still running Rhino 6. Just to be safe, and if you have the opportunity to do it, always check that the definition is working as expected in Rhino 6 before uploading it.

In this case, you are running into one of the classic retro-compatibility issues between Rhino 6 and Rhino 7: in Rhino 6, the “Offset Curve” component does not output any results if the “Plane” input is left empty:

If you provide a plane, everything works:

I added the “Planar” component on the input curves and used the computed plane, but if possible pull the plane from your definition if it is available somewhere, for better performance. As an additional note about performance, I think you can significantly reduce the size of displayed meshes.

Note that, as a designer user, you can request your account be switched to the Rhino 7 system. If you would like to try this option, please contact us directly.

I added the planes and it works :slight_smile: I will try the Rhino6 test before uploading next time. thank you!