Shadow Issues

Hello, I really don’t understand what is going on with the shadow and rendering here.
I have reset both the Render and Raytracing modes.

Render mode simply does not cast shadows

Raytracing is giving some really wierd results after 1000 passes

any ideas?

Far from origin?

Oops, Thank you Nathan.
It was a quick model based on a 3rd party dwg and I didn’t realize it was indeed very far from origin.
Thanks, N

Any ideas about this one?
This is the corner of a building, you can see from the projected shadow of the ducts that the sun comes from the left. the face on the right should be darker (much darker). In the rendering mode there are simply no shadows. Distance to origin is reasonable (65 meters).

raytracing 1000×: image
rendered mode: image

Thanks, N

With enough diffuse bounces and/or skylight enabled you won’t necessarily get dark shadows.

Without knowing settings and scene setup I can only guess, though.

Hi Nathan,
Let me know what settings you need to know. I currently have the default settings, I believe it is 32 bounces.
In the meantime, the rendered mode issue seems to have to do with the area of the scene.
I made a simple model where I increased the base square surface gradually. The first is 20×20m and the shadows hold. The next if 80×80m and the shadows are still ok. The third is 120×120m and the shadows are not be good enough anymore. With 400×400 they are totally blurred and actually when you zoom in they almost disappear.
On a small sized project, with some surroundings, or on a medium sized project, this is unmanageable.

Are there any settings that can be adjusted?

I am wondering if it is a similar problem with the raytracing.






What is the model unit setting? Is it meters, or millimeters?

Anyway here the plane has sides of 244km long in a millimeter model, sun works just fine in Raytraced

Hi @nathanletwory
I started from the template Large objects meters (see file attached).
230518 Shadow.3dm (434.7 KB)

I guess I have two complaints in this thread (which is never good).

  1. One issue is: In the rendered mode, the cast shadow disappears with the extent of the scene, even with very minimum geometry. In the attached file, besides the test with the increasing planes, I moved one wall 100 meters away. Even with the 20×20 plane the cast shadow dissolves. This is likely at the origin of a previous complaint ( Quick Question: should display mode rendered show shadows when sun is on? - Rhino / Rhino for Windows - McNeel Forum).
    Open the attached file; sequentially turn on layers plane200x200 and plane400x400; then turn off those two layers and turn on Geom100m.

    20×20 > > 400×400

  2. The other issue is: Both in raytracing mode and in rendered mode, the face shade is very faint, especially in contrast with the cast shadow that ends abruptly on the corner. The shaded surface should be closer to the cast shadow, than to the lit surface. In fact in the examples below, it actually looks that the shaded faces are lighter than the lit faces…
    Open the attached file and notice is on views 001 in rendered and raytraced mode.


This is because you have an environment in your skylight that lights from that side as well

Hi @nathanletwory
I have the default Rhino environment
Adjusting the environment background color to a darker color improved. Although it is difficult to make it work both on raytracing and rendered mode.

Still if you have a slightly larger scene, the rendered mode is basically unusable. Any ideas there?
Thanks, N

larger scene >>

I can’t speak much to Rendered mode, Raytraced is my area. But again, the default environment you use is also set to be the skylight custom environment. The orientation it is at will light from the side you saw the shadow “abruptly ending”.

You need either to find a skylight environment that has sun-like light source in roughly same location. Or add a basic environment and set as texture Physical Sky Texture with Use Document Sun checked.

So who is the rendered mode guy? As much as I like raytracing, if you have a bunch of elevations where you need shadows rendered mode is the way to go… or it would be if I knew how to make it work.

Thanks for the replies on the raytracing. That physical Sky Texture is well hidden, and knowing this changes the game in what you can achieve. Is there a setting where shadows can be softened? As in a cloudy day?

In the meantime, on my side by changing the time the shadows are updated but the sun doesn’t move. You need to exit raytraced mode and re-enter. Is this expected? (see below)

at 16:00

changed to 17:00

still 17:00 but after any other display mode and back to raytraced

thanks, N

8 posts were split to a new topic: Raytraced viewport not getting to set sample count

Hi @nsgma,

In Rendered mode, the resolution of the shadow map that we create depends on the extent of the scene, because the shadow might extend that far in the worst case. The larger the scene, the less shadow detail on a specific area in the scene. It’s not ideal, but it has been like this for several Rhino versions.

You can improve the situation by increasing the maximum shadow map resolution in the Shadows settings (Rhino Options → View → Display Modes → Rendered → Shadows → Video Memory usage / Shadow Size). Drag the slider to Maximum and it should look much better (although not perfect).

Does this solve your problem?