Quick Question: should display mode rendered show shadows when sun is on?

That’s about it.
I think it should but I may be wrong as it doesn’t show shadows on my end.

Typically yes, but object settings may affect the working: receiving and casting shadows settings for instance.

Maybe share a simple file where you expect sun shadows to show up but aren’t.

@wim @nathanletwory
I am now using a proper hardware so the time is not a issue.
I am also working with a much lighter file.
However, the shadows are not really good in elevation.
Those gaps should not exist.
Any ideas?

Hi Nuno -
I’ve moved your post to this thread as it seems to belong better here.

Can you post a simple file that we can take a look at?

Here it is.
This is the view on model space perspective

This is the view on elevation in layout

My complaint was regarding that non-shadow area signed, but here shows even a larger difference in the elevation.
The whole area should be shaded.
230322 Shadow Render.3dm (222.0 KB)

I don’t understand what is going on and what I am looking at in your shared file, but if I switch the rendered view to plan and zoom to the object I see

It looks like this because it is viewed from “below” I suppose? Rotating the view (cmd+shift+rotate) I see

Anyway, I am useless with layouts, so I let @wim do the rest :slight_smile:

yes. Look from below to see the under side of the horizontal surfaces and you will notice that there is a small “illuminated” area where the horizontal surfaces meets the vertical surfaces. This “illuminated” area is much larger in the layout view.

Right, this is probably something for @DavidEranen to look at, he’s the Rendered master.

Hi - this is for @jeff since this looks like a shadow map issue. I tried changing the shadow map resolution in the options (Shadow quality) and it made the situation better but didn’t eliminate the problem.


This, unfortunately, is just the nature of how shadow mapping works, and is one of the pitfalls it suffers from.

The reason this happens is twofold:

  1. Shadow mapping suffers from “self-shadowing” artifacts. Meaning, a single surface can/will cast a shadow onto itself… To prevent this from happening, the shadow map depth buffer is biased slightly away from the camera for each object. This can cause issues where two or more surfaces intersect and is known as “light leaking”…and it exists in every single shadow mapping implementation.
  2. Shadow mapping tends to produce very aliased edges, since they’re based on the contents of a depth buffer, the results tend to have stair-stepped edges. In an attempt to reduce that effect, the edges are “softened” via a series of filters.

Those two things combined can/will contribute to “light leaking”…and there’s really no way around it.

That being said, you can turn off the self-shadowing adjustment and the edge softening to make this look a little better, but you may then run into the other problems they were designed to solve.

This is what I get when I turn “Self Shadowing Artifacts” all the way to the left (“Dirty”) and “Soft Edge Quality / Speed” all the way to the left (“None/Faster”).

But results can/will vary depending on hardware and drivers.


Also note: That completely turning off self-shadowing will probably cause all kinds of strange banding to occur on flat surfaces at certain camera angles.


Hi Jeff,
Thank you for the explanation.
Does that explain also the “light leaking” (rather flooding) in the elevation layout view? In that case it appears that the horizontal surface is one or two meters away from the vertical.

Sort of… But that looks more like a depth precision issue (which can also impact light leaking) due to the camera frustum being REALLY deep/long. In an orthogonal view, you don’t really need to have the camera that far away from your objects…doing so limits the depth ranges that can exist (they’re stretched out across a much longer distance), which can have all kinds of quality issues in the shadow map…and loss of fidelity.

Try unlocking the detail view, select your object and run “Zoom Selected”… That will readjust your camera to a more reasonable frustum. Now just use the mousewheel or Zoom to reposition the object back to where you had/want it.

If there is a reason you want extremely long, flattened frustums, then I’m afraid shadows in those frustums are going to suffer the same fate.


Note: To see the different camera frustums:

  1. Activate one of your details.
  2. Run “ShowCamera”
  3. Go back to something like your Top view and you will see a wireframe representation of the camera frustum for the view you ran “ShowCamera” in.
  4. Run “HideCamera” to turn it off.

You will see how long and stretched out your detail frustums are…which is fine, if that’s what you want or need…but it’s not a good situation for shadow mapping.


Not sure I understood and I am not behind Rhino right now. but the issue on the layout is an elevation, therefore the point of view is by definition in infinity and the perspective is parallel.
I guess I could zoom to select to make sure the target of the camera in on the objects themselves (maybe that makes a difference), but then I would have to readjust the scale of the view because I want the view to be to scale. I doubt that you can turn ShowCamera on a parallel perspective.
I have included the 3dm file on the original post so that you can see if you have the same results.

Hi @jeff
ZoomSelect reduced the gap substantially, but it is still noticeable.

I have noticed that if I extrude the surface (or even if I gave it a thickness) sufficiently the gap disappears. Unfortunately, in this case the thickness of this material should be only 0.01 or less and that is not sufficient to reduce the “light leaking”. Again in some situations that could work. My guess is that in this case, the other surfaces (especially the perpendicular) of the solid shade the gap and the “Soft Edge Quality” softens the corner enough.
image image

Reducing the “Self Shadowing Artifacts” and “Soft Edge Quality” has mixed results that could work is some situations, but it is not ideal.

However, combining taking both the “Self Shadowing Artifacts” and “Soft Edge Quality” to zero and increasing the “Edge Blurring” substantially seems to give better results than the default.
Are any know draw backs situation from this settings? and why were the default chosen instead of these?
Thanks, N

Because as mentioned, with these settings completely turned off, many configurations would experience some kind of artifacting and/or banding. Just because you’re not seeing it, doesn’t mean others wouldn’t…which is why it has all been made configurable. The defaults we arrived at are all based on extensive testing across a broad spectrum of video card makes, models, and drivers, as well as OS versions.