Shaded Viewport Problem

Anytime I make any movement in the shaded viewport, the picture seems to freeze and duplicate every frame. Has anyone else experienced this? Does anyone know how I can fix it?



Hello -

Please run the SystemInfo command in Rhino and copy/paste the results here.


Rhino 6 SR29 2020-8-25 (Rhino 6, 6.29.20238.11501, Git hash:master @ 06b936ae4e8c289ecccfd6b5ee9bacccc60eded1)
License type: Educational, build 2020-08-25
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 5-19-2020 (M-D-Y).
Primary OpenGL: NVIDIA Quadro T2000 (NVidia) Memory: 4GB, Driver date: 4-23-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 425.45

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-23-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Users\nlatt\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\KeyShot9RhinoPlugin (ecfe8d1f-876a-460f-aa5e-3dd816936811)\\KeyShot9RhinoPlugin\Rhino 5.0\KeyShot9RhinoPlugin.rhp “KeyShot9RhinoPlugin”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - first please try disabling the Vray and Keyshot plug-ins in Options > Plug-ins page. (Uncheck ‘enabled’). Then close and restart Rhino - does that work any differently now?


No, it’s still happening

Hello - OK - your drivers are not ancient at all but it may be that a refresh of the video drivers will help - please look in the Notifications panel (Panels menu > Notifications) and see if there is something about rhe drivers there - if so, double-click and follow the directions to get a newer driver. Please get new drivers for both the Intel and the nVidia cards - we’ll see how that does.


I just installed both new drivers, but it’s still happening. I ran SystemInfo to confirm and it says the newest drivers are installed. the Intel driver date is 8-5-20, and the nVidia date is 8-12-20

Hello - one more thing - can you see if the nVidia control panel has a control to force ‘high performance’ for the display? If so, and it is not set, please set that.


I changed the ‘Prefered graphics processor’ to ‘high performance NVIDIA processor’ in the nVidia control panel, but that did not help the issure either.

Hello - ok … yet another thing to try - in the NVidia control panel someplace there should be a setting for ‘vertical sync’. On mine it is here:

Please try turning that off.


Unfortunately, there’s still no difference. I’m really sorry about this.

OK, I need to ask around some more here. Can you please verify that disabling the plug-ins mentioned earlier do not affect this? To make sure, disable these, with only one Rhino running, then close Rhino (important) and start it again. If that is what you did, and ir had no effect, then that is fine, I just want to make sure about that because plug-ins can have seemingly random effects.


That is what I did. I disabled them and haven’t touched them since.

Wait! This happened to me! Did you previously have an image as a background? If you moved the location of that image background it will do this. Set background to default color in display preferences.

That’s it!! Thank you so much!

Thank you for all your help Pascal, the problem has been solved

@pascal: This does sound like a bug though, doesn’t it?

@Jesse_Gates, @nlatta524 - can you please give me the exact steps to reproduce the problem?
Never mind, I can reproduce this. Good catch, thanks.
RH-60411 Display breaks if background image is moved