Shaded View does not work

Hi,
I have been trying to set my viewport to the shaded view - however it doest work - but all of the others.
Is it possible that my Computer does not fullfill the system/hardware requirements for this view to work?

Rhino 6 SR14 2019-4-28 (Rhino 6, 6.14.19118.15561, Git hash:master @ 8f0a84997c310a7ec1a42cf2704da8daa33e3e21)
License type: Evaluation, Build 2019-04-28
License details: Stand-Alone
Expires on: 2019-06-10

Windows 10.0 SR0.0 or greater (Physical RAM: 8Gb)
Machine name: DESKTOP-12EG9UJ

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce 9800 GTX/9800 GTX+ (NVidia) Memory: 1GB, Driver date: 11-14-2016 (M-D-Y). OpenGL Ver: 3.3.0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 3.3
Shading Language: 3.30 NVIDIA via Cg compiler
Driver Date: 11-14-2016
Driver Version: 21.21.13.4201
Maximum Texture size: 8192 x 8192
Z-Buffer depth: 24 bits
Maximum Viewport size: 8192 x 8192
Total Video Memory: 512 MB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Do I need a new grafic card with a higher version of Open GL 3.3.0 ?
I cant quite figure out what the problem is.
Thanks in advance!

Update your driver first - that one’s like 2.5 years old.

The problem is, this is the latest driver…
Thanks for the quick reply!

Hi Melanie,

Yes, I’m afraid that for Rhino 6, a GPU with support for OpenGL 4.1 or higher is required:
https://www.rhino3d.com/6/system_requirements

Hi Wim,
I just read that : Rhino 6 will use OpenGL 3.3 (if available), and fallback to older specifications when required. (https://wiki.mcneel.com/rhino/rhino5videocards)
So is there maybe another problem?

Hi @melanie.paetsch
That’s an 11 years old graphics card - I think it might be time for an upgrade :slightly_smiling_face: I know it sucks, but V6 requires a lot more oomph from the graphics card than V5 did.

-Jakob

Hi Melanie,

That page was was primarily for Rhino 5 and was last updated in 2017 - before Rhino 6 was released - so I would read Rhino 6 will… as a declaration of then future intent rather than an imperative. But the requirement was subsequently overtaken by advances in the OpenGL spec.

I guess McNeel need to clean the misleading page up, but Wim supplied a link to the current Rhino 6 requirement.

Jeremy

Hi Melanie,

Rhino 6 will use OpenGL 3.3 (if available), and fallback to older specifications when required.

Thanks for pointing that out. I’m not convinced that this statement is correct - I’ll run it by the developers.
At any rate, even if that statement is correct, it doesn’t say that the fallback to older specifications will actually make things work as they are intended to work.

Thanks everybody for the quick help!
So basically the only solution is - if I get that right - to buy a new graphic card or install Rhino 5 instead?

Hi again,
I got more information from the developer. Rhino 6 will run at the OpenGL level that the GPU reports to be supporting. Your card claims to support 3.3 and Rhino 6 will use that to draw the viewports - but this is clearly not working on your machine.

One thing that you could try first is using a test command - TestGlLevelCap and set this to 21 (for OpenGL level 2.1). You will have to exit and then restart Rhino 6 after having used this command.
Note that this command was added to Service Release 15, which is now available as a SR Candidate - you will have to change the Update frequency in Rhino Options > Updates and Statistics to automatically download a SR 15 version.

The command forces Rhino to use a specific level of OpenGL and thus override what the GPU claims to be supporting. We have a set of drawing routines that use what was available for OpenGL 2.1 and hopefully this will make display modes work for you - no guarantees though…
HTH,
wim

Hi Wim,

I tried your sugested command with 21 - all the viewports went black. Setting it to 33 made it normal again but still no shaded view Is there anything else I could try?
Thank you!

Hi - a quick question. If I understood that correctly, you originally wrote that all other display modes work. Is that right, does e.g. Rendered and Raytraced work fine?

Yes that is correct! Only the shaded view is the same as wireframe and doesnt show the surfaces as supposed…For example instead of a sphere, I see three rings.

Did you restart rhino after running the command?

Yes, I did! Everytime after altering the level of OpenGL.

Strange! When you expand Rhino Options > View > Display Modes, is the text “Shaded” printed in blue or in black letters?