Viewport display problem

Having problems with viewing model in shaded and wireframe views. If I zoom out a little bit from the model, the display colors get out of whack.
This is what I am seeing:

When it should look something like this:

Any ideas would be helpful. Thanks.

Hello - it looks like your model is over the World origin but it could be a custom CPlane showing - can you confirm that the model’s not out in space? If it is not, then can you run SystemInfo command in Rhino and paste the results here, and if possible post your model or send to


It is close to the origin, not perfectly over it though. As for the SystemInfo command:

Rhino 6 SR10 2018-11-7 (Rhino 6, 6.10.18311.20531, Git hash:master @ 0f9089a0035dcc6955732d57071445ecc29390f0)
Licence type: Evaluation, build 2018-11-07
License details: Stand-Alone
Expires on: 2018-12-25

Windows 8.1 (Physical RAM: 7.9Gb)
Machine name: SEANLAPTOP

Intel® HD Graphics 4400 (OpenGL ver:4.2.0 - Build

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.2
Shading Language: 4.20 - Build
Driver Date: 8-26-2013
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2080 MB

C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

The Model:
Hopefully.3dm (1.2 MB)


Hello - thanks. That driver date is what leaps out at me - that is ancient history as these things go - I would see if there is an update available from Intel’s website and install that. That said, I’m not sure how good it will get with that video chip.


Understood. I am looking at intel to try an update that. However, this problem only started yesterday, and I have been working on that model intermittently for a few weeks now. Is there anything else that might work?


Hello - did Windows update itself in the last day or two?


I believe it did, but that normally occurs when I shutdown or turn on my device, but I am not 100% positive as I do not normally pay the device much attention until I am prompted to login to it.

OK - please try the driver update and let us know how it goes - that may be enough to get things back in sync.


Does the model also look incorrect in “Rendered” display mode?

A little but not nearly to the same extent as shaded and it is only while panning.

Updated the driver and that seems to have fixed the problem.

Thanks Pascal and Steve.

Great, thanks for letting us know.