Shaded view shows simple shape as transparent AND opaque


#1

Hi, check this screen shot out as it shows it all

The shape is just a basic bowl with default materials but you can see the inside is transparent but the outside is opaque???

It is a single surface


(Pascal Golay) #4

Hi Vatom - can you please post a file with object or send to tech@mcneel.com?

thanks,

-Pascal


#6

hey @pascal

this has happened to me a few times lately… here’s a file that shows the behavior (using a shaded viewport)

loftttable.3dm (3.8 MB)

this is what happens on my computer:
(and happens with this file even if i quit rhino then relaunch / re-open the file)

it’s only happening in the WIP for me and not showing up using the latest official version 5.3.2 (5D197)

Software information

Software versions
Rhinoceros version: 5.4 WIP (5E78w)
Rhinoceros path: /Applications/RhinoWIP.app
IronPython version: 5.1.2015.131
WIP expiration: June 16, 2017
Language: en-US (MacOS default)
macOS version: Version 10.12.4 (Build 16E195)

Plug-ins
None

Third party kernel extensions
com.intel.driver.EnergyDriver (2.0) 6EC99BBD-0CA2-3CA6-B252-DE46782936C3

Hardware information

Computer hardware
Hardware model: iMac14,2
Processor: Intel Core i7-4771 CPU @ 3.50GHz
Memory: 24 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GTX 780M 4096 MB
Memory: 4096 MB
Screen size: 2560 x 1440, 1920 x 1200
Displays: iMac (109dpi 1x), SyncMaster (94dpi 1x)

USB devices
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)
Logitech: USB Receiver
C-Media Electronics Inc.: USB Audio Device
Apple Inc.: Apple Keyboard

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.16.34 355.10.05.35f05
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 8x
Mip map filtering: None
Anisotropic filtering: None


Dark backfaces in WIP
(Pascal Golay) #7

Hi Jeff - I see the problem here as well - Running Flip or Dir ‘fixes’ it - I can’t quite tell from your clip what command you used, but I will log the bug - thanks.

(This appears to be fixed in the latest here)

-Pascal


#8

i used Flip.

but after doing that, the same thing happens except now when selecting the object.