'set object display mode' not working for custom modes

hi,
i’m experiencing an issue where custom display modes cannot be used when running the ‘set object display mode’ command. the ‘allow assignment to individual objects’ box IS checked for each custom display mode, but i can still only select from the preset modes. i found a thread from someone dealing with the same issue posted in March, but there was no solution given other than reinstalling rhino completely. is anyone else experiencing this, and is reinstalling my only option?
thanks.

Make sure no space in display mode name so it can be valid option via command line

i have no spaces in any of my display mode names. :slightly_frowning_face:

ok, that was my first guess as I’ve done that. So if no spaces or other non-standard characters, not sure why modes as option names wouldn’t come up. If you type setdisplaymode do they come up as options?

yes, they do show up if i type ‘set display mode’

Hello - are your custom modes copies of one or more of the defaults? Which one? If you make a new mode from scratch, does that work?

-Pascal

some are modified copies, others i’ve made from scratch.

Hello- can you export and post one or more that you cannot get to work? We’ve seen this more than once now (not here, but users) , but so far it’s not clear what happens.

-Pascal

here is a file i just created for you to look at. i have not been able to get any files opened in rhino 6 to set object display mode.

SetObjectDisplayMode_Test.3dm (29.5 KB)

Hello - to export a display mode, please go to Options > View > Display modes, select the mode and click on Export at the bottom of the window.

-Pascal

sorry, i misunderstood what you were asking for. here’s two display modes, one created entirely from scratch and one that is a modified copy of a preset.

SF_Rendered_Material.ini (11.4 KB)
Copy of Rendered 01.ini (11.3 KB)

Hello - thanks - so far we have not seen the problem you describe but have found others…

https://mcneel.myjetbrains.com/youtrack/issue/RH-46440

-Pascal

thank you for taking a look. i’m not sure where to troubleshoot from here. i used this command a lot in rhino 5. any other suggestions?

If you open the *.ini, about ten lines down you will see a line that reads Order=XX - Try changing that value to a unique negative number, save the *.ini, and re-import it into Rhino. If you look in Options->View->Display Modes, the first listed display mode will have the lowest order number. Over here, that is Wireframe which for me has an order number of -10, so some number below that. It will mean that when you assign your display modes lower numbers they will float to the front of both the SetObjectDisplayMode list and to the top of the list in Options->View->Display Modes. Other than that, it seems to work well as a work around.

Sam

1 Like

thank you sam, that worked!

Woah, Sam, excellent catch… but something is still amiss with how this all works it seems to me. I’ll see if we can fix it. ‘We’ being Jeff, I imagine.

-Pascal

@pascal, all,

Are you still seeing this problem? Many fixes went into SR6-SR8 in this area, and so far, I cannot reproduce this crash in the latest build of V6.

Please see if you guys can, and if so, let me know…and please provide your Rhino version.

Thanks,
-Jeff

hi jeff,
my original issue does not seem to be fixed in the latest build of V6. if i create a custom display mode and then run the ‘SetObjectDisplayMode’ command, the recently created display mode is not displayed as an option. in order to be able to set my object to that mode, i have to export the .ini file, change the order, and reinstall it (so that if falls above the default modes), per sam’s solution in this thread.

@sef.nola How are you creating the custom mode? Take me step-by-step through what you’re doing…

Here’s what I’ve tried so far, and all of it works…

I go to Options->View->Display Modes

  1. I click the “New” button to create a new mode
  2. Close the dialog
  3. Run SetObjectDisplayMode
  4. Pick an object
  5. Click “Mode” in the command line
  6. I can see my new mode in the list

… I’ve also done these same steps only for the first step I click the “Copy” button, and make a custom mode from a copy of something like Shaded… it too shows up in the command line list of modes.

So obviously I’m not doing what you’re doing, and my guess is that you may be trying to make a copy of mode that’s possibly corrupted in some way, which propagates to any copies you make of that mode.

Let me know the exact steps you’re taking…and if you are copying an existing mode, then please export that mode and post it as well.

Thanks,
-Jeff

i stand corrected! i just tried making a brand new display mode using the exact steps you described (which is how i usually do it) and it showed up when i ran the ‘SetObjectDisplayMode’ command. it also worked when i copied one of the preset modes. when i tried it before my initial response, i must have copied an already existing mode…unfortunately i don’t remember which one…and like you said it must be corrupted. there may actually be several corrupted modes because i don’t have the same number of modes when i run ‘SetObjectDisplayMode’ as i do in my display modes list under options. i guess one of these days i’ll have to go through and duplicate each on and see if it shows up when i run the command to determine which ones are corrupted. thanks for following up on this!