BUG: set object display mode doesn't work for custom modes


(SMN) #1

Hi,
there is an issue when doing set object display mode on individual objects. when runing the command set object display mode the only options you have are the default modes but it doesn’t let you apply to any custom/ or new ones.
On my case i have 3 different ghosted modes for different transparencies and it only let me assign objects to the default ghosted mode. I know there is a setting on each mode to “allow assignment to individual objects” but this seem to have no effect.
is there anything im missing?
Thanks!
Simon F Alvarez


(Pascal Golay) #2

Hi Simon - make sure the custom modes are set to show up in the list - this is set in the display mode setting > ‘Other settings’ page.

-Pascal


(SMN) #3

Hi Pascal,
Thanks for your reply,
That was the first place we check but it didn’t solved the issue. The only way we were able to solve it was to reinstall rhino in the computers affected. We are importing the shaded modes that we had already established one by one, thinking that one of them could have caused the error. we have being using some of these shading modes for quite some time.


(Pascal Golay) #4

Hi Simon - if you still have one of these modes that does not cooperate can you please send me the ini file?

thanks,
-Pascal


(SMN) #5

Hi Pascal,
we haven’t been able to find the shade responsible for the error, and so
far we haven’t encounter the error again after reinstalling rhino. if we
find the mode that causing the error i would send it to you right away,
thanks for checking again.

Simon F Alvarez