Server Busy

error

#1

Hi,

2-3 days already it takes Rhino about a minute to start loading. Meanwhile I’m getting the server busy error.
I’ve just tried to see if any upgrades are available from the Help menu and I got another server busy…

Any idea what should I touch to fix that avoiding reinstall (if possible)
Thank for helping


(Pascal Golay) #3

Hi Alex - I would try, just as a test, launching the Rhino exe right from the installation folder, or use the NoSplash switch on the Rhino icon and launch from that - is it any better?

-Pascal


#4

Hi Pascal,

it does not get better launching the Rhino exe directly, nor when adding /nosplash because widows reports a "Problem with shortcut"and does not allow to be applied.

I’m getting Server busy also when closing Rhino.
Whats next? :frowning:


(John Brock) #5

Try running the “Services” Windows tool.
Find the McNeel Update Service.
Stop it and change the Startup Type to Manual or Disabled:

This will mean you’ll need to manually check for Rhino Service Release updates.
I expect SR14 will be finished up and available in less than a month.


#6

Yes, that helped! thanks a lot.
It’s just that news and tips fields are empty but never mind.

cheers


(John Brock) #7

Right.
The Server Busy message is coming from your local Windows.
Rhino uses the WIX Windows service to check for updates and download them in the background. This is the same service Windows itself uses. Other applications may as well. What’s happening is Windows is getting a “log jamb” of requests for the WIX service and it is reporting back to Rhino that is is too busy.