Rhino slow to load

For the last few months, Rhino is sometimes very slow to load:

  1. after clicking on the icon, or a .3dm, rhino object appears as a background process but does not actually start.
  2. after several minutes I get a system prompt saying that ‘the action cannot be completed because the other program is busy. Choose ‘switch to’ activate the busy program and correct the problem’
  3. choosing switch to does nothing
  4. I wait longer, sometimes an hour, then it starts and works perfectly.

Many years ago (around 8-10 or so) I had the same problem and never quite got to the bottom of it, but it went away.

I have tried the following so far:

  1. loaded it in safe mode. It starts, but of course then doesn’t really work because you can’t actually work in safe mode. I 2. don’t have any plug ins anyway.
  2. I’ve uninstalled, re-installed.
  3. turned off the antivirus software etc.
  4. run it not connected to a network (no difference and not a solution of course)

Thanks for your help in advance.

I think what’s going on is Rhino is trying to start the service that checks for updates. This is a shared Windows service and the same one Windows uses for it’s own updates. The service tells Rhino it is busy.
When Windows itself is done with with checking for and downloading updates, then the service is available for Rhino to use.
There are a variety of things you can do.
1 - Change your Windows update settings to it checks for updates when you want it to
2 - Turn of Rhino’s check for updates service

Personally, I chose option 1. If ind Windows checks for updates at the most inopportune times and constantly gets in the way. I check for Windows updates on my own schedule.

Clearly, how you choose to manage this is up to you.

Thanks John. I’ll try that.

Do you think Rhino could have a timeout to manage that sort of startup clash? Windows update is kind of important too.


I don’t think the Windows Update service has that option. It just runs and queues up.
I chose to do the Windows updates on my schedule since it interfered with lots more then Rhino.


Changing windows update didn’t work. I changed update so that it only occurs when I say so, and Rhino till suffers the same delayed start-up.

PS: I think I was misunderstood. If Rhino clashes with updates, which are essential, why not fix Rhino so that it doesn’t just sit there doing nothing if Windows is currently working through some supposed update procedure? i.e. it would be the case that Windows is fine. Rhino is not fine.

Anyway, like I said, update is not the problem.

If there are either ideas, I appreciate them.


Also, just to add: it only happens in 64b Rhino.

This sounds more like Rhino is trying to load something and not managing. Do you have any startup scripts set up?

Above, you said no plug-ins, but Rhino has its own native plug-ins that have to load. One of them might have gotten corrupted. If Rhino starts in safe mode, try loading plug-ins one-by one and see if/where there is a problem…

Other things to look at - since 32 bit Rhino runs - what might be the difference between the two setups?

Anything special about your system? Using latest service release?


Thanks Mitch,

I meant that there are no ‘non Rhino’ plug ins.

I’m not sure that is where the problem lies. If I start in safe mode, I can load all the Rhino plug ins fine. It is even the case that if I have one prior instance of Rhino going, I can start second instances fine. The problem is getting that first instance going.

The same problem has happened more occasionally before over the last 8 years, it is just that now it is a daily occurrence. I’m sort of giving up after a year of it.

There really is nothing special about my system and I am using the latest service release and have done everything anybody can really do without help from the supplier. I even tried re-installing windows 8 (requiring a reinstall of Rhino too), then upgraded to Windows 10 (no required reinstall, but I did it anyway. The problem is exactly the same.

My feeling is that it may be to do with the Rhino Splash screen (the one with the icons of the last 6 files I had open). I think it is somehow looking for those last files, and if they are unavailable/moved/in use etc it won’t open properly?

PS: there is a new problem with Rhino 64b (not 32b) since I installed Windows 10: I can’t drag and drop files to import them anymore.


one prior instance of Rhino going, I can start second instances fine.
The problem is getting that first instance going.

Older 3DConnexion/3D-motion-controller, whith usupported driver, connected ?
Or other device ?
This may take time to load dll’s…

You can easily check that by running Rhino in a no-splash mode.
Modify or copy one of your Desktop shortcuts by adding the /nosplash argument to the Target line. Like this:

"C:\Program Files\Rhinoceros 5 (64-bit)\System\Rhino.exe" /nosplash


That fixed it!