Server Busy / Switch-To error (Updates and Statistics)

Hi all,

I am running the latest release of Rhino on Windows 10 and consistently getting a ‘Server Busy’ error when I attempt to load Rhino. I ran it in Safe Mode, disabled some plug-ins as well as accelerated graphics and narrowed it down, I think, to something happening when I enter Updates and Statistics in the options menu.

Is this a known bug / does anyone know if there have been any Windows / Rhino updates in the past few hours that could potentially have caused this? I would be grateful if anyone could offer any help with this.

Ryan :slight_smile:

Hi Ryan,

Try this:

1.) From Windows, go to Control Panel -> Administrative Tools - >Services.
2.) Find the “McNeel Update Service 5” service, right-click on it and pick Properties.
3.) If the service is running, click Stop.
4.) Change the startup type from Automatic to Disabled.
5.) Click OK to close the dialog.

Does this help?

– Dale

Hi Dale,

Thank you for your reply. This seems to have helped.

Just to mention for others: Rhino began to open normally some time after my original post, but the problem entering the Updates and Statstics menu remained.

Ryan

HI this helped me enormously. but does it mean the updates are disabled?

Automatic updates, yes. You can always check manually. (Help -> Check for updates)

Hi, I am also having this problem but that doesn’t help me. I have the same issue over and over where I download rhino, I can run my analysis and then after using the software for a couple of hours or days (depending on the power of the computer) it stops coping.

Does rhino save the processes that you’ve been running? Am I somehow clogging up it’s memory as I run analysis?

Any feedback on how I can overcome this issue would be greatly appreciated as I have up scaled to the largest computer available to me! And I know it is not a computer issue as like I said when I begin analysis the software copes and runs beautifully.

A big thing I did that reduced this issue was that, at each step in my analysis saved a file and then ran the next analysis on a separate file, Thus reducing the memory of each individual file.Again, this leads me to beleive that Rhino is storing info in some way??!!

Thanks,
Kath

Hi,

I’ve followed the same explanation and still got this message when running simulation.

I can still get accurate result, but i won’t to be ride of the message.

Does anyone knows?

Best regards,

Frank

Which version of Rhino are you running?
What kind of simulations are you running? Is there a plug-in involved?

Hi,

In the end turning off “Advanced hardware acceleration” is what helped me. Here is the link to the page. This worked on my mac and windows machine.

https://wiki.mcneel.com/rhino/5/video/troubleshooting/intel/intel

Hope this helps!

Hi,

@wim I’m using Rhino 6 and doing a daylight simulation with DIVA for Rhino. There is plug-in involved such as grasshopper-archicad live connection, and therefore diva for rhino.

@Kath, thanks Kath, I’m gonna try to turn off “Advanced hardware acceleration”. I’ve contacted Rhino’s support and it seems that the only way it to turn off this automatic update but it seems that I still have this problem sometimes.

Thanks for your support.

Frank